1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Boss plow problems

Discussion in 'Boss Plows Discussion' started by kcplowman, Dec 10, 2009.

  1. kcplowman

    kcplowman Member
    Messages: 63

    I bought the truck with the plow on it. The ford dealer installed the plow and i am kinda unhappy with how they installed it. First problem is that when you take the plow off of the truck the truck lights do not work unless I unplug a wire is there a way to fix this did they maby install it wrong. And also the blade is slow and it dims the lights when the pump runs what could be causing this. The truck a 2000 f250 with a 5.4 and the plow is a 8.5 straight blade rt3 with smarthitch. Any help would be greatly appreciated. Thanks
  2. RamDude01

    RamDude01 Member
    Messages: 41

    Hey kcplowman, it's normal for some dimming of the lights. What wire do you have to unplug? There should be a switch inside the truck that says 'truck/plow' that switches the lights from one to the other. There is an adjustment nut and allen screw on the back of the motor tower to adjust the drop speed. Just loosen the nut and give it a little turn to adjust the speed. You can go to bossplow.com and download a pdf of the user manuals and that will show you what to do. Good luck.