1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Boss Plow Lights…. I have high beam, no low beam

Discussion in 'Boss Plows Discussion' started by kj3033, Feb 6, 2014.

  1. kj3033

    kj3033 Junior Member
    Messages: 5

    First year plowing snow. I have a 99 F250 Super Duty Diesel with a 8.2 straight blade. My plow lights will work on high beam only. I have red, white and blue wires from the harness to my headlights on the truck. There are 4 relays, I switched the relay that has the red/yellow wire with the blue yellow. Still, no low beam lights. Per the dealers instruction the relay that has the red/yellow wire is high beam and the blue yellow is the low beam. Dealer is $80 per hour plus parts, minimum 1 hr labor plus parts. Any help is appreciated!
     
  2. maxwellp

    maxwellp PlowSite.com Addict
    Messages: 1,112

    Do the low beams work on the truck?
    Did you check the bulbs to see if the low beams in the plow lights are good?
    I once fixed the running and turn signals on a plow that the owner was convinced it was a wiring problem because none of the running or turn lights worked. The bulbs were all broken from vibration.
     
  3. kj3033

    kj3033 Junior Member
    Messages: 5

    Max,

    Thanks for your response… see my response below.

    Do the low beams work on the truck? Yes
    Did you check the bulbs to see if the low beams in the plow lights are good? Yes
    I once fixed the running and turn signals on a plow that the owner was convinced it was a wiring problem because none of the running or turn lights worked. The bulbs were all broken from vibration.
     
  4. maxwellp

    maxwellp PlowSite.com Addict
    Messages: 1,112

    If you only have 4 relays there should be 2 fuses. One to the battery and one to a keyed source. Are they good?
    Did the lights ever work?
    Does the plow work?
    Sorry for the dumb questions, just seeing what could be wrong.
     
  5. kj3033

    kj3033 Junior Member
    Messages: 5

    If you only have 4 relays there should be 2 fuses. One to the battery and one to a keyed source. Are they good? I will check these fuses tomorrow!
    Did the lights ever work? Yes
    Does the plow work? Yes
    Sorry for the dumb questions, just seeing what could be wrong. Only dumb question is the one you don't ask!
     
  6. alpine779

    alpine779 Member
    Messages: 70

    I had low beams with no high beams. Green Death corrosion in plug was the problem. Cleaned the plugs up added some grease. Good to go
     
  7. kj3033

    kj3033 Junior Member
    Messages: 5

    Alpine779,

    I will also check for corrosion. Thanks for your response!
     
  8. GA73

    GA73 Member
    Messages: 90

    ditto had same identical problem
     
  9. krazykracker

    krazykracker Junior Member
    Messages: 1

    having the same issue. plow is 7 year old 13 pin v never have had one issue with it took it off yesterday to work on the truck put the plow back on an hour later and my low beam lights do not work. All lights work on truck with switch in truck light position with switch in plow light position the plow has all marker lights blinkers and HIGH BEAM head lights just no LOW BEAM head lights. The bulbs are the H I D style. fuses are good as well. Any help is greatly appreciated