1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Boss hooking up problem

Discussion in 'Boss Plows Discussion' started by johntwist, Dec 5, 2005.

  1. johntwist

    johntwist Senior Member
    Messages: 415

    I've had my 8 foot Boss straightblade for 2 seasons now and have never had a problem until today.

    I went to hook up as usual, connected the cables, put the controller in 'float', but when I hit the toggle switch to raise the headgear it woudn't budge. :mad: Nothing but the solenoid clicking. Now, this is with the truck running, good battery, all connections solid., etc. Couldn't find any bad fuses either.

    Went to the manual under troubleshooting, and didn't find anything relating to this. :confused:

    Any of you who have had this problem and may be able to point me in the right direction as to how to get her fixed without having to go to the shop, I'd appreciate it. Thanks!
     
  2. Randy Scott

    Randy Scott Senior Member
    Messages: 142

    We just replaced the switch on ours, did the same thing. If all your grounds are good, it may just be the switch. Switch is $30.
     
  3. Exciteable

    Exciteable Member
    Messages: 38

    Probably the solenoid...
    Pretty cheap item available at your Boss dealer.
    Last one I replaced I think it was around 20 bucks...
    While you are there, buy 2. I've heard they are a pretty common thing that takes a s*it
     
  4. johntwist

    johntwist Senior Member
    Messages: 415

    Replaced the solenoid and everything is back to normal. Thanks for the advice. I figured that's what it was, but in the pinch I wanted to throw it out there anyway just in case. We can't afford to waste time being down when the white stuff's coming down now can we??