1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Boss headlights won't work

Discussion in 'Boss Plows Discussion' started by FF_Opie, Feb 2, 2012.

  1. FF_Opie

    FF_Opie Junior Member
    from Midwest
    Messages: 5

    Howdy all,

    I did as much searching as my eyeballs will handle and couldn't find an answer so I thought I would start my own thread. I have an RT3 8'2 Vee on a 2006 Chevy Duramax. All lights work properly except the headlights on the plow. Amber running lights and blinkers are fine. Truck lights are fine. Problem is nothing happens when I switch the in cab truck to plow switch. I have been just using the truck lights but it sure would be nice to use the ones on the plow! From some of the searching I did do it looked as though the headlights on the plow have their own ground seperate from the rest? I will look into this but thought I would see if anyone has had this specific problem.

    Thanks in advance
     
  2. RepoMan1968

    RepoMan1968 Senior Member
    Messages: 439

    to get you started ,
    wiggle (clean) your bumper mount plug
    check plow headlight switch / ground
     
  3. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Going to assume this is a 13-pin harness....


    Check the relay pack for corrosion in the relay sockets first. Then use a test light to check all brown wires at the relay pack for ground. If it all checks out good there, next disconnect the two black wires at the truck/plow lamp switch in the cab and connect them together with a jumper wire, turn the ignition on and see if the plow lamps work.

    We can continue on from there if needed.