1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Boss Headlight issue RT3 no highs (lots of info)

Discussion in 'Truck & Equipment Repair' started by AccuCon, Feb 17, 2014.

  1. AccuCon

    AccuCon Senior Member
    from CT
    Messages: 440

    Truck: 2005 F350 6.0
    Plow: Boss 8' Super trip edge RT3 2006

    Ok so I have been having some issues with my plow lights and I think I may know what the problem is but I just want a second opinion, plus maybe I am over looking something. Here is the details:

    I have low beams, however they have been sketchy lately. The high beams no longer work and when I go to switch them to high all I get is a dim on the low beams. The lights failed on me after 24 hours of straight plowing and it occurred while I was raising the plow stacking a bank during the previous storm.

    When the truck master light control is switched to parking lights only the low beams stay on (plow only).

    When switched from plow to truck all truck side lights work as should.

    All fuses check out.

    I have cleaned the connections on the truck to plow connector with electric cleaner.

    Grounds have been checked.

    Everything else works fine.

    Recently replaced the light housings with new Boss OEM housings.

    Plow side wiring harness connector was replaced prior to winter.

    I am thinking it's the relays since they are original and being on for 9 years may be at end of life.

    Any ideas? Thanks.

    ~edit

    I pulled the lights out, and put my multi-meter on the high beams connector with the truck running and highs on, no voltage.
     
  2. AccuCon

    AccuCon Senior Member
    from CT
    Messages: 440

    So I replaced all four relays to no avail. I suppose it's time again to bust out the multi-meter and test lights and recheck everything.

    Any suggestions would be greatly appreciated, thanks.
     
  3. AccuCon

    AccuCon Senior Member
    from CT
    Messages: 440

    Ok so it was not the relays. After tracing all wires I discovered a short in the new pig tail connector, apparently the terminations failed and caused the high and low beam wires to contact briefly. And then corrosion set in and completely severed the connections (Green death from loose connections/shorting).

    For future reference, disconnect your plow wiring connection and locate pins seven and eight truck side, and check voltage. You should be reading 12VDC if the relays are working when you switch between high and low. High being pin seven with the blue and yellow stripe wire and eight being low with the red and yellow stripe wire.

    However I know have another issue when the lights are set to plow and the truck selector switch is on parking lights the low beams stay on. Any suggestions to this?
     
  4. maxwellp

    maxwellp PlowSite.com Addict
    Messages: 1,112

    Stay on when? when you turn them off? As in you can't turn them off at off?
     
  5. AccuCon

    AccuCon Senior Member
    from CT
    Messages: 440

    No everything goes off when the truck side selector (not the truck/plow switch) is off. It's in the parking light position that the low beams stay on (plow only).

    Everything when set to truck works fine its only in plow and its only the plow lights.
     
    Last edited: Feb 27, 2014
  6. maxwellp

    maxwellp PlowSite.com Addict
    Messages: 1,112

    re check your wiring job on the 13 pin connector. Did it do this before the "no high beam problem" started?
    It takes power to fire the low beam relay. This could just be a short - wiring problem - ground problem.
    Stuck relay?

    Parking wire is connected to the headlight power?
     
  7. AccuCon

    AccuCon Senior Member
    from CT
    Messages: 440

    Well I rang out all the plow side wires when I was repairing the failed connections and everything rang true no shorts, I will double check. I'm thinking its something truck side but plow harness related.

    I'll check tomorrow and post my findings.

    -Edit
    I've been browsing this thread as well

    Plowsite "Boss Plow lights won't turn off"

    The wiring diagrams are a bit to be desired and it would be nice if the relays were labeled.
     
    Last edited: Feb 27, 2014
  8. maxwellp

    maxwellp PlowSite.com Addict
    Messages: 1,112

    Did you check the truck side 13 pin connector?
    Short chafed wire.