1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Boss -conneection plug issues.

Discussion in 'Boss Plows Discussion' started by Pa Teeny, Feb 6, 2012.

  1. I have a Boss 9'2" that is giving me fits over getting the controller to work....I plug in the connection and try to use the toggle to connect the plow......it engages the cylannoid but no motion. I wiggle the connections and have clean the contacts that they shine and are brand new looking. It is still under warrenty and I need to see if it is still under warrenty ( As there is always a reason it is not covered..) as it is frustating to have issues with a new plow.

    Hope it is covered....
  2. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,106

    Is it in float? Is it connecting the plow or disconnecting. I had a similar problem disconnecting, but it turns out that I was forgetting to toggle up to disconnect the pins. I spent 20 min before I felt like an ass.
  3. No I know to have it float and toggle up to disconnect.....it is electrical issue as a connection or contact....I'm thinking a male connection is bad.....in the plug......I read about splitting the male....but they do not spead and I did not try it as it is 18 months old......

    I will call dealer and see what they can do...
  4. Earthscapes

    Earthscapes Senior Member
    from WNY
    Messages: 577

    Theres a little connection "cage" inside the plug. They rot out and fall off. You cannot spread the newer cables like you could with the older ones.... I just had this problem with my 14 month old vxt. I took it over to a friends (Snow Dogg Dealer) and he fixed it in about 5 min.