1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Boss 8' straightblade problem.

Discussion in 'Boss Plows Discussion' started by Sharpcut 1, Dec 7, 2006.

  1. Sharpcut 1

    Sharpcut 1 Senior Member
    Messages: 386

    I have a Boss 8' Strtaightblade RT3 I believe with Smarthitch 2. The raise/lower cylinder does'nt work. When I send 12V to the coil with the white wire and unhook the hose at the rod end of the cylinder, I have steady stream of fluid. Same with the orange wire, except I get steady fluid out the base hose. If I hook up to the cylinder, the pump runs,and then lock up. Do I have a bad cylinder?? There is too much pressure in cylinder hoses, they get tight and you can hear pump/ motor strain, but cylinder goes nowhere. Could I have an airlock?? how can I get the cylinder to respond if I do. Thanks in advance for any help. JOHN
  2. Sharpcut 1

    Sharpcut 1 Senior Member
    Messages: 386

    back to the top
  3. Makndust

    Makndust Senior Member
    Messages: 324

    I would suggest getting on Boss's web site and e-mailing them with these Questions. I have been in touch with them before and they are very fast to respond. I have three V's , 1 with RT3 and 2 with RT2 and I have never had that problem. Good Luck,