1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Bolting problem

Discussion in 'Fisher Engineering Discussion' started by Banksy, Aug 6, 2009.

  1. Banksy

    Banksy PlowSite Veteran
    Messages: 3,113

    I mounted my Minute Mount onto my 98 today (kit #7157).

    There are about 4 bolts I can't get in. The box frame makes it impossible. They are the bolts on the rear parts of the mounts (driver and passenger side). I didn't have a Fisher bold kit handy so I took the parts list off Fisher site and got everything I needed at Lowes hardware section.

    How do I get these bolts in? I can weld on handles, but I don't know where to slide them in.

    Any suggestions?
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Should be an access hole on the inside of both frame rails further back. Passenger side hole is usually square and not as large as the one on the driver side.

    You will need to weld a steel strip to the bolts to act as handles in order to get those four bolts in place.
  3. Banksy

    Banksy PlowSite Veteran
    Messages: 3,113

    Ok, I'll look for those access holes. I'm sure I saw them, but didn't think they would work. Thanks BB.
  4. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,990

    We use grade 5 carriage bolts with plates and fish wire them though the access locations B&B discussed.
  5. Banksy

    Banksy PlowSite Veteran
    Messages: 3,113

    I like the fish wire idea. Thanks again.
  6. BigDave12768

    BigDave12768 PlowSite.com Addict
    Messages: 1,446

    the metal strap is the best. Did you take the bumper off?
  7. Banksy

    Banksy PlowSite Veteran
    Messages: 3,113

    No I didn't take off the bumper. I didn't see where I was supposed to per the instructions. I had to on my 2004 though.