1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Bolt for 8500 Vibrator

Discussion in 'SnowEx Products' started by Mark13, Jan 14, 2014.

  1. Mark13

    Mark13 PlowSite Fanatic
    Messages: 5,734

    Has anyone had the factory SnowEx D6515 vibrator apart and had to source the little carriage bolts that hold the end covers on the electric motor? Mine decided to snap one of the carriage bolts inside the motor and then allow each half to work itself out until the spinning weights jammed on them. From what I can tell the bolts are 10-32 by 3.5" long. Can't find them locally, McMaster Carr only goes to 1 or 1.5" long, and googling it comes up with no carriage bolts that fit that size, machine screws only. Ideas?!
     
  2. JeepCoMJ

    JeepCoMJ Senior Member
    Messages: 284

    Do you have a local shop that rebuilds electric motors, starters, alternators? Stop by them, they will take care of you
     
  3. Mark13

    Mark13 PlowSite Fanatic
    Messages: 5,734

    Genoa City, Wi or Dekalb, IL I think is my only options. Genoa City is about a half hour and Dekalb is an hour. I'll ask around tomorrow but I don't think there's anything closer.
     
  4. JeepCoMJ

    JeepCoMJ Senior Member
    Messages: 284

    Maxim rebuilders in Burlington, wi. Located on highway 83 south of the bypass.


    Can you text me a pic of what you are looking for with a measurement on length? 26221004sevensix

    Also if it looks like fine thread or coarse
     
  5. ultimate plow

    ultimate plow PlowSite.com Addict
    from N. IL
    Messages: 1,760

    Mark, had mine rebuilt last month at a shop by my house here in algonquin. Im sure you had it taken care of already though.
     
  6. Mark13

    Mark13 PlowSite Fanatic
    Messages: 5,734

    Sorry for the lack of responses, been keeping pretty busy. I was able to get it taken apart and find a few more problems with it. Got it all back together and going.