1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Blizzard will not go up, down, left or right?

Discussion in 'Blizzard Plows Discussion' started by Mike S, Dec 16, 2008.

  1. Mike S

    Mike S PlowSite.com Addict
    Messages: 1,588

    My blizzard 810 will not go up, down, left or right but the wings go in and out. The motor runs in all functions but nothing happens. I check all conections and can not see a problem but Im guessing its a one of the coils I just dont know which one. The 810 will some times go up and down when you use the power hitch switch but it doesnt always work. Also when you put the plow in float the light will blink on the control. :help:
  2. flykelley

    flykelley 2000 Club Member
    Messages: 2,124

    If it was me I would call the blizzard wizard. (aka) Jerre of Jerres Service in Erie PA.

    Regards Mike
  3. Mike S

    Mike S PlowSite.com Addict
    Messages: 1,588

    I would but I dont have his number.
  4. Jerre Heyer

    Jerre Heyer Senior Member
    Messages: 948

    Mike, Actually sounds like a bad valve or two or a bad ground wire lug. Check your main ground on the plow and the group of red wires connected to the ground. Next is the plow in mid air that it won't drop or are you only talking power down. I'd lean to bad #3 or #4 valves causing bleed by back to the tank. J
    Last edited: Dec 17, 2008
  5. bluerage94

    bluerage94 Senior Member
    Messages: 398

    I'd recheck the conectors, I've had that happen a couple of times and it was the connector.
  6. Mike S

    Mike S PlowSite.com Addict
    Messages: 1,588

    Jerre thanks for jumping in!!!!!!!!!!! It does it in mid air and on the ground with the power hitch and the control but it mainly doesnt work on the control and sometimes goes up and down on the power hitch.
  7. fastjohnny

    fastjohnny Senior Member
    Messages: 653

    Sounds like a valve hanging? Do you have good voltage? Poor connections + and - can cause a coil to not fully engage a valve.
  8. Mike S

    Mike S PlowSite.com Addict
    Messages: 1,588

    I checked all conection and cleaned and put di electric grease on all conections. We will go through them again and doulble check.