1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Blizzard solenoid?

Discussion in 'Residential Snow Removal' started by 907Ralph, Dec 13, 2012.

  1. 907Ralph

    907Ralph Junior Member
    Messages: 2

    I have older Blizzard plow that just that is not responding to joy stick. Was told it was solenoid and replaced it with new one. When I started it again, I still got a clicking noise and that was it. After about 4-5 mins with truck running I tried again and I had full control again. Then when I plowed into something that caused plow to hook left I lost use of joy stick only to hear clicking sound but getting no control. Anyone have any ideas? Thanks
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,972

    Well you need to test,,,not guess. Test light the 2 small terminals one is gnd and the other is triggered pwr.
     
  3. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,169

    Either the harness plug is loose and not connecting properly, clean it up plug it together tight. or you have a frayed wire coming from the joystick control. Pink one I think it was on mine.
     
  4. 907Ralph

    907Ralph Junior Member
    Messages: 2

    Thanks for quick response! I will try that and any other ideas tomorrow during our short daylight hours!