1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Blizzard plow no power

Discussion in 'Blizzard Plows Discussion' started by Duramaxallison0, Jul 3, 2012.

  1. Duramaxallison0

    Duramaxallison0 Member
    Messages: 40

    So I was selling my truck and the day before it was supposed to be sold my plow had no power at all when I hooked up to it. Plow lights worked. I didn't hear any noise from the solenoid when I tried mounting. I did check all wiring and didn't find anything wrong. Solenoid most likely chance? I dont have the truck anymore but guy still wants plow. Any help would be great.
     
  2. wizardsr

    wizardsr PlowSite.com Addict
    Messages: 1,557

    PH1 or 2? Dumb question, but was the power switch on? Check the fuse? Test the trigger wire at the solenoid with a test light? So many possibilities... [​IMG]
     
  3. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,983

    Controller fuse ok?
     
  4. Duramaxallison0

    Duramaxallison0 Member
    Messages: 40

    Where is controller fuse? Only one I found was for lights I think. What are all the fuses for the plow so I can buy one of each . Ill buy solenoid also
     
  5. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,983

    its somewhere in the cab.....its a red wire....probally coming outta your fuse box in a nonfactory way