1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Blizzard 8100 power plow issue

Discussion in 'Blizzard Plows Discussion' started by primecut1, Nov 15, 2014.

  1. primecut1

    primecut1 Junior Member
    Messages: 3

    he guys, not getting power to my controller. thought it might need a new controller and had one one hand but still didnt work. any thoughts on where to look from here?
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,980

    Fuses, power wire to the controller, plow hooked up while cking this correct?
     
  3. primecut1

    primecut1 Junior Member
    Messages: 3

    Power harness's hooked up but can't raise plow and attach since no power?
     
  4. 04trd

    04trd Senior Member
    Messages: 162

    Kind of stupid question but did you trace your power and wires back from the battery? maybe one of them came loose or did a prong come out in the plugs that go from the plow to the truck?
     
  5. primecut1

    primecut1 Junior Member
    Messages: 3

    I did. Now I have found that there is power going into the control module for plow under the hood but not coming out. if there's no power coming out of module then there would be no power to the controller right? Sorry electrical is way over my head.
     
  6. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,980

    Did you Ck your fuses??