1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Blizzard 810 problem

Discussion in 'Blizzard Plows Discussion' started by 04trd, Nov 15, 2014.

  1. 04trd

    04trd Senior Member
    Messages: 162

    Hey guys I recently got to try out my new to me 810 power plow. Worked great but maybe I'm doing something wrong. After using it for about an hour or more the left wing wouldn't retrsct in all the way, it would fold out and like snap back than go out. I'm assuming some how snow got packed in there or is something else up?the wing would be extended out about 3 inches and not go in anymore. I took it back to the shop and steam cleaned inside the pocket where the wing slides and it seems to be working fine. Any suggestions?
     
  2. fastjohnny

    fastjohnny Senior Member
    Messages: 654

    Sounds like your assessment is correct. Try to keep the slide boxes washed out and lubed between events. Make sure you are not low on fluid. A pump sucking air will also give erratic performance.
     
  3. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,972

    Usually just snow. As said lube the entire slide box assm
     
  4. 04trd

    04trd Senior Member
    Messages: 162

    Cool thanks guys I appreciate the fast responses. I sprayed some fluid film in there but may try some grease or something along those lines