1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Blizzard 810 Power Plow Problems

Discussion in 'Truck & Equipment Repair' started by prayforsnow, Dec 2, 2005.

  1. prayforsnow

    prayforsnow Member
    Messages: 35

    Howdy All,

    I hope someone here can tell me how to fix this 3 year old plow, before I replace it with a perfectly operating 20 year old plow and thirty year old lift unit. :help:

    First off the power hitch only works occasionally. Sometimes it will reach out and grab the truck when you hit the switch,other times the pump whines like fluid isn't flowing and it will either move a fraction of an inch, or not at all. If you keep flicking the switch (sometimes twice,sometimes 20 times) it will work. Kinda' spooky when it's ON the truck...knowing you can't get it off unless it lets go. :eek:

    It also does the same thing when lifting...it will lift it a foot (once), 6 inches couple times), just preload the front suspension (several times), or not lift it at all (what I ended-up with). I take it the same hydralics work the lift and power hitch? :confused:

    And yes, I had the hook thingy (purely technical term) up out of the way and pinned.

    The power angle works strongly, and the wing operation seems to work alright...

    All four hoses for the plow operation were disconnected this summer for a while so I could fix one of the wings, if that makes a difference.

    How do you loosen the solinoids to bleed the switch block? How do you test the solinoids? :confused:

    Any help anyone can give would be greatly appreciated...thanks in advance.

  2. LwnmwrMan22

    LwnmwrMan22 PlowSite Fanatic
    Messages: 27,862

    I know we're comparing apples to oranges here, but I've got a new Boss straightblade that's going back to the shop today.

    The tower doesn't want to lift up with the toggle switch on the side to latch onto the truck, or release without a stiff tap from my shoulder.

    Everything else works perfectly fine.

    When I find out what's wrong, I'll post it back here again and maybe it's something you can troubleshoot on your Blizzard???
  3. prayforsnow

    prayforsnow Member
    Messages: 35

    I'll keep an eye out...

    Thanks a bunch,