1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Blinking Status Light

Discussion in 'SnowDogg Snow Plows' started by NTO, Dec 14, 2011.

  1. NTO

    NTO Junior Member
    Messages: 26

    Hey Gang

    Put the VMD on the other day for the first snowfall of the year and guess what....Blinking Red status light. Blinking 4 times and no Left Wing Extension. When I push the left wing out, both wings go out real slow. Checked in the Tech Support section of the website and didn't really help me too much. Brand new plow, just wondering if it's something simple or should I just take it back to the dealer. (45 min ride)

    I checked all the wiring connections and everything seems fine, just puzzles me.
     
  2. smoorman

    smoorman Sponsor
    Messages: 446

    In order for it to be blinking, something is not connecting (broken wire, bad pin, etc.).
    4 blinks is the orange wire to valves S3A and S3B. Focus on the orange wire, starting under your dash - see if maybe the pin pushed out of the white connector (that the controller plugs into). That orange wire runs straight from there to the grill connector. On the plow side it splits into two wires (one for S3A and one for S3B). As BOTH would have to be damaged on the plow side for the controller to blink, the problem is more likely on the truck side or in the connector.

    Truck side harness issues are pretty unusual - as it's a brand new plow, hopefully the pin in the controller connector just wasn't seated properly.

    If you find nothing obvious you will, unfortunately, have to visit your dealer. The first thing to try would be a new controller.
     
  3. NTO

    NTO Junior Member
    Messages: 26

    Thanks Scott...I'll check it out when I get home today.
     
  4. NTO

    NTO Junior Member
    Messages: 26

    After crawling around under the dash and hood, and not finding anything obvious. I decided to call the dealership and take the plow in for service. Was in there most of the day Friday and was working directly with the mechanic on the plow. After 2.5 hours, found that the harness coming out of the plow has a broken orange wire in it. (Thanks Scott!) Ordered a new plow side harness and going to install it this week. Everything should be fine after that. I'll keep you guys posted.

    Bob:drinkup: