1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Blinkers work on plow but running lights dont?

Discussion in 'Boss Plows Discussion' started by HULK2184, Jan 16, 2009.

  1. HULK2184

    HULK2184 Member
    Messages: 77

    I just notice that my plow running lights don't come on, i thought when i bought the plow the lights went on too.

    The blinkers seem to work just fine and i think i noticed the running lights comeon the off a few times plowing the other day. But is there a relay that maybe went bad or wiring somewhere i can check out?:dizzy: Anything help would be great!
  2. johnslawn

    johnslawn Member
    from ma
    Messages: 90

    Try replacing the bulbs. All the bouncing strecthes the filaments.
  3. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    The relays have no bearing on the marker lights. They're wired directly from a tap into the trucks marker wire directly out to the plow through the bumper plug. Check at pin #11 for 12V with the markers on to see if its a truck side or plow side issue.

    If it's on the truck side it's likely the connection point where the installer tapped into the trucks marker harness.

    If its on the plow side then check both bulbs for broken filaments (as John mentioned). If they check out good start going through the plow side harness looking for a broken/chaffed yellow wire.
  4. HULK2184

    HULK2184 Member
    Messages: 77

    Perfect, Thanks a bunch guys ill check it out today and see what i find.