1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Blade wont go up

Discussion in 'Truck & Equipment Repair' started by GHI1127, Oct 16, 2009.

  1. GHI1127

    GHI1127 Junior Member
    Messages: 12

    I have a older meyer e-47 pump it gos up without the blade but when i hook up the blade it wont go up it tries to but wont it also will angle left but wont go back to center or left i replaced orings in lift cylinder any suggestions would be great
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    You likely have more than a single issue.

    For the lack of raise and you're 100% positive you replaced every seal and O-ring in the lift ram the next thing to check is to be sure the A valve isn't stuck open.

    The lack of no right angle check both the quick couplers and also the C coil to be sure it has magnetism. If both check out then check the C valve itself for proper movement.

    Head over to the Meyer specific forums and search "magnetism", "valve" and "coupler" and you'll find a treasure trove of diagnostic info and procedures related to you're question.
     
  3. GHI1127

    GHI1127 Junior Member
    Messages: 12

    Thanks i will check all those
     
  4. GHI1127

    GHI1127 Junior Member
    Messages: 12

    I did replace the A coil and valve but now i have fluid coming out of the small hole on the front of the pump body just below the 12v motor. anybody know what causes this or how to fix it
     
  5. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    It blew the upper seal out of the gear pump.

    Best to just replace the gear pump as a whole vs taking the time to only replace the seal just to have it blow out again due to the pump being worn out. As that's what normally causes it to take the seal out in the first place....a worn pump.
     
  6. GHI1127

    GHI1127 Junior Member
    Messages: 12

    Thank you for the info
     
  7. GHI1127

    GHI1127 Junior Member
    Messages: 12

    i replaced coupler and coils i checked the valve the are moving but the plow is still stuck left im lost