1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Blade-less Western Set-up, Couple of ???

Discussion in 'Commercial Snow Removal' started by k5blazer, Dec 18, 2003.

  1. k5blazer

    k5blazer Junior Member
    Messages: 12

    Hello all, I have been lurking and searching here and my questions are:

    1.) I have a Western cable operated set-up minus blade and A-frame and I want to know what blade/A-frame will work if I can't find a Western blade in my area & price range.

    2.) The truck mount came off an 86 Chevy mason's dump and I want to put it on my 86 K5 Blazer. The diagrams I downloaded from Western's site show a 2WD and a 4WD installation (different part numbers). I have the 2WD mount according to the diagrams, any reason why this won't bolt up? The 4WD diagram shows a thrust arm going from the spreader back to the frame and I can fab these if I need to.

    I will be using (hopefully) this rig to plow my driveway (1/4 mile) and a neighbor or two. If that goes well, I may add/upgrade and expand next year.

    Thanks for the help, this board is great and y'all seem really helpful.
  2. Mdirrigation

    Mdirrigation Senior Member
    Messages: 408

    I may have a blade that will work for you , I am in maryland near annapolis. Email Mme Rachett1@aol.com I will nead some measurements from you Matt