1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

beacon blowing fuse

Discussion in 'Strobe Lighting' started by t.i.b, Jan 19, 2009.

  1. t.i.b

    t.i.b Senior Member
    Messages: 140

    anyone know why a target tech light would keep popping it fuse? its a magnet mounted 1 with 2 revoling lights and just plugs into the lighter. it keeps blowing the buse fuse thats built in to the thing that plugs into the lighter. i dont see any breaks in the wire.
     
  2. SKYNYRD

    SKYNYRD Senior Member
    Messages: 420

    i'm no wiring expert by any means but try a bigger fuse, if there's a real problem even the biggest fuse will blow. since you didn't see any broken wire my only other thought is to plug the light into a different lighter. maybe there's a problem with the one you're using? i'm sure there's someone on here though that will have more advice. hope you get it fixed soon.:salute:
     
  3. festerw

    festerw Senior Member
    Messages: 986

    Putting a bigger fuse in is not a good idea, bigger fuse=more amps=more heat. That said you need to look at your plug, internal connections on the bar and the motors.
     
  4. t.i.b

    t.i.b Senior Member
    Messages: 140

    i looked at them, problem is i dont know what the hell im looking at!
     
  5. festerw

    festerw Senior Member
    Messages: 986

    Start with easy things, melted connections, corrosion. Try unplugging one of the motors and see if there's an issue, then the other. Look for one spinning slower than the other, one making more noise.
     
  6. CityGuy

    CityGuy PlowSite Fanatic
    Messages: 16,984

    you might also check the fuse for the lighter itself it might not be able to handle the load? just a thought
     
  7. t.i.b

    t.i.b Senior Member
    Messages: 140

    maybe i miss read the amp on the original fuse? thought it was a 5 but the lighters a 15 should the one in the plug be a 15 too?
     
  8. CityGuy

    CityGuy PlowSite Fanatic
    Messages: 16,984

  9. SKYNYRD

    SKYNYRD Senior Member
    Messages: 420

    my whelen light calls for a 10, 5 does sound kind of small to me
     
  10. t.i.b

    t.i.b Senior Member
    Messages: 140

    its been a long day but if thats the dumbest thing ive done its been a good one.
     
  11. SKYNYRD

    SKYNYRD Senior Member
    Messages: 420

    we've all been there at some point my friend. i've been there millions of times lol. stay warm and happy plowingussmileyflag