1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Battery question

Discussion in 'Chevy Trucks' started by CSLC, Oct 23, 2012.

  1. CSLC

    CSLC Senior Member
    Messages: 260

    Ok, since I have learned so much from PS, I figured you guys might be able to help me on this one. The truck is starting hard lately, I have had the battery tested and alternator tested both seem to be good. But I have had one battery test tell me I have a bad cell in batt. I have a red top with CCA of 800 now. I was told I might need a yellow top with CCA of 770. I don't want to get into doing a dual battery install right now. I just need one that will power the truck, stereo and plow. What is everyone's suggestions? Can I get just a new battery for the main and use old one for accessories?
     
  2. grandview

    grandview PlowSite Fanatic
    Messages: 14,609

    Dump the old battery and get the biggest one that will fit. I've been using the NAPA emergency vehicle one. I only run one battery in my trucks.
     
  3. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,926

    Agree with the only need one batt. So what's the starting issues your having?
     
  4. 1olddogtwo

    1olddogtwo PlowSite Fanatic
    Messages: 11,503

    I like double d's in my truck
     
  5. CSLC

    CSLC Senior Member
    Messages: 260

    It has been starting hard, especially when it is a little colder out.
     
  6. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,926

    Ok. Little more info. What kinda motor. What kinda hard ?
     
  7. grandview

    grandview PlowSite Fanatic
    Messages: 14,609

    Sounds like that bad cell is going even badder!
     
  8. CSLC

    CSLC Senior Member
    Messages: 260

    6.0L it is cranking hard like it doesn't have enough power.
     
  9. Plow More

    Plow More Senior Member
    Messages: 172

    Could be a bad starter as well... but sounds like your battery is bad if one cell is bad
     
  10. REAPER

    REAPER 2000 Club Member
    from 60050
    Messages: 2,228

    If you have another vehicle that you know has a good battery switch them for a day and see if your hard starts continue.

    I would assume you have clean terminals and good grounds already covered.
    A bad cell tho will be a plow stopper in the middle of a long push/run during winter and would for sure get it taken care of now.

    May be the time to also upgrade your alternator. NAPA sells a 200 amp that I put in mine. Keeps everything charged and lights bright all night long.
     
  11. CSLC

    CSLC Senior Member
    Messages: 260

    Ok, so I could start it when I left work yesterday. I drove it around a bit no problem. I parked it when I got home, went to start it this morning and nothing. I jumped the truck with my gf's car. It started but then stalled. I started it again and left it running for an hr. I don't go into work till seven. I have to go to dr's around lunch time not sure if it will start. So what does everyone think? Battery still?
     
  12. leolkfrm

    leolkfrm PlowSite.com Addict
    Messages: 1,403

    i would pull and check the battery cables, might have an end starting to corrode or a ground that has rubbed and created a bad spot.....a battery for a diesel would approach 1000 cca....as grandview mentioned bigger is better but it will cost more..@125
     
  13. leolkfrm

    leolkfrm PlowSite.com Addict
    Messages: 1,403

    another thought after rereading your intentions....not a good idea to mix new and old batteries..as it will cut the life of the newer battery
     
  14. CSLC

    CSLC Senior Member
    Messages: 260

    So I guess, I am working on the truck this weekend....YAY!!!! So, I will check grounds and battery cables. Any one elses input would be greatly appreciated. I am stumped on this and I need to get it fixed before the snow flies!!!!
     
  15. CSLC

    CSLC Senior Member
    Messages: 260

    Can you use this alternator if your current one has a 2 pin? This looks like a 4 pin.....
     
  16. the new boss 92

    the new boss 92 2000 Club Member
    Messages: 2,989

    when the trucks running disconect the battery and see if it stays running, if it doesnt bad alt. if it does take a load tester and test the alt like a battery and see if it holds at the same spot. if it does then replace your battery. if the truck stalls while testing your alt replace that its no good, you can narrow it down real quick that way!
     
  17. CSLC

    CSLC Senior Member
    Messages: 260

    I did the alt test, it stayed running. I think the battery is shot.
     
  18. REAPER

    REAPER 2000 Club Member
    from 60050
    Messages: 2,228

    Yes, just tell them eggsactly what your truck is. I have pretty much the same truck as you only mine is an 2004. Alternator bolted and plugged in like it was stock.
    If you go that route (which I highly recommend) you also want to upgrade the cable going from the alt to the battery to 2 gage I did that and also my ground wire and have had 0 problems since and like I said it keeps everything nice and charged during those long nights with no worries at all and I have more electrical stuff on my truck then a lot of guys do. :salute:
     
  19. Plowtoy

    Plowtoy Senior Member
    Messages: 929

    Really bad advice. Thats the best way to fry your computer and other electrical componits. That way worked in the 70s and early 80s but nothing was computer controlled then.

    You should go out and buy a lotto ticket.
     
  20. CSLC

    CSLC Senior Member
    Messages: 260

    Well went out and got the right battery for all my electronics and installed it but new problem!!!!! When I turn truck off and pull key, open door, the radio stays on. The interior lights come on and stay on. I close the door and the lights will go out but radio will stay on as if it has key in acc mode. Any help on where to start would be nice.....