1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Bad_Luck 2

Discussion in 'Truck & Equipment Repair' started by repo_man62, Dec 8, 2005.

  1. repo_man62

    repo_man62 Senior Member
    Messages: 502

    Got a couple inches. Mistake #1= woke up at 7a.m...:angry: Got the coffee goin' and started the plowtruck. Lifted the blade,turned it left & right,dropped it back down, did my drive, pushed a couple blocks of my road, lifted it back up. Went to my first account and back bladed the handicap spot at this gas station. Lifted it back up to do the outside fuel island, dropped it down, pushed 1 pass, went to lift & NOTHING!:realmad: :realmad: Thought it was the solenoid(NOT),short chained it and took it to my shop. Seems to be froze...took the motor off and it turns fine....turned the shaft in the pump and it moved fine. But it looked like a smoothie inside the pump. Any idea's??:dizzy:
  2. Get some straws where coming over for smoothies!!!!purplebou J/K
  3. Playboy

    Playboy Senior Member
    Messages: 335

    Was anything loose on the pump? Sounds as if water or air got in.
  4. repo_man62

    repo_man62 Senior Member
    Messages: 502

    Nothing loose...may have got condensation in it. I'm gonna flush and re-fill it after it thaws out.