1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

back blade pump wont lift

Discussion in 'Truck & Equipment Repair' started by JTS Landscaping & Lawn Service, Dec 6, 2012.

  1. i have got a power up power down monarch pump. went to hook it up and the pump has down pressure to lift the back of truck up. but when to to lift the blade it doesnt want to lift when under load. thinking maybe flow control valve possably not sure.
  2. Herm Witte

    Herm Witte Senior Member
    Messages: 546

    Check toggle / rocker switch, then quick coupler. If you have flow control, open it up or remove to aid in finding your issue.
  3. miderbier

    miderbier Member
    Messages: 95


    Mine was doing the same thing...I would bet the filter inside the resevoir is clogged. Thats what mine was. Take the filter out and clean it or replace it. Great time to change the fluid anyway.
  4. i had the pump check out and everything on pump is good. when then lift cylinder isnt hooked up it goes all way in and out so know my switch is good yet. thinking now that its the power plug or the the ground. i had the thing working just fine all last year. i also just stuck a new flow control valve on for heck of is to just see what happens. ill find out tomorrow when hook it all back up.
  5. wasnt flow control valve. when the lift cylinder isnt hooked up it goes in and out just fine. got to thinking maybe the battery i have doesnt have enough power like need a bigger one. but my front blade lifts and all just fine. i do have a tad bit smaller battery in truck then use to have.
  6. forgot to mention also though that if i lift it up by hand and flip the switch will go up about a inch each time i do that. instead of powering down it pretty much just slams to to the ground