1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Automatic Transmission 89 chevy 2500

Discussion in 'Chevy Trucks' started by milwaukeevtwin, Nov 28, 2009.

  1. milwaukeevtwin

    milwaukeevtwin Senior Member
    Messages: 335

    I have to get up a lot of rpms to get the tranny to shift. It acts like it wants to stick before it shifts also. Drives fine once it shifts, but seems like i have to get it over 65 mph and then let off. Any suggestions?:dizzy:

    NICHOLS LANDSCA PlowSite Veteran
    Messages: 4,286

    Check the Vacuum line to the tranny. TH400 right?
  3. milwaukeevtwin

    milwaukeevtwin Senior Member
    Messages: 335


    Yes th400. I just install a new vacuum line with clamps. I think i am going to try the piece that the line goes into on the side of the tranny. I will see if this helps.
    Thanks, Ron
  4. TLB

    TLB Senior Member
    Messages: 274

    That is the one you want to check.
    If their is a split in that line you will need a lot of speed before it shifts into 2nd, & can't get 3rd either.

    Let us know if it fixs it.
  5. Sydenstricker Landscaping

    Sydenstricker Landscaping PlowSite Veteran
    Messages: 3,882

    If that doesnt do it, try and replace the vacuum modulator that goes into the side of the trans. I had this same issue on my 84 K20. Replaced all the lines, rubber pieces and the vacuum modulator. After that it was good to go. Also wouldnt hurt to do a fluid/filter change too since that fluid has been getting heat up real good with the hard/high rpm shifts.
  6. milwaukeevtwin

    milwaukeevtwin Senior Member
    Messages: 335


    Replaced the modulator and hoses and does the same thing. I am goin to install a new metal tube. Maybe there is a crack in it? Any other ideals?
  7. the new boss 92

    the new boss 92 2000 Club Member
    Messages: 2,989

    cheack the fluid level out of chits and gigles. possibly a bad torque converter?
  8. milwaukeevtwin

    milwaukeevtwin Senior Member
    Messages: 335


    Fluid is fine. Replaced tube. Same thing! Is the Torque converter next? Any other thoughts? Man i hate to think about another tranny?
    Thanks, Guy's
  9. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    First, verify that you actually have vacuum from the hose. Pull if off at the modulator with the truck running to see if it's there. A vacuum gauge would be the correct way to do it if you have one. Or a finger will suffice for now.

    If you do in fact have vacuum, remove the modulator again and using a set of needle nose pliers pull the modulator spool valve from the trans. Is it free to move? If so, remove it and reach in and remove the spring behind it to verify it isn't collapsed or broken.

    Forget about the torque converter or a trans rebuild, neither will be necessary. It's either one of the causes above or a valve is stuck in the valve body. Neither of which require a complelte trans rebuild.
  10. milwaukeevtwin

    milwaukeevtwin Senior Member
    Messages: 335

    Fixed tranny

    Thanks, For all the help. Good vacuum pressure to Modulator. Bad new Autozone modulator. Imagine that. I pulled a used one off my other truck and it workd perfect. Installed autozone one on other truck and did not work. Took it back went to Advance and got one put it on and presto. Works perfect.
    Thanks, Ron:drinkup:
  11. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Good to hear Ron. :drinkup:

    Here's another tip, stay away from those discount store parts. The discount isn't so great when you have to do the job twice. :rolleyes:
  12. milwaukeevtwin

    milwaukeevtwin Senior Member
    Messages: 335


    I usually go to NAPA, But they are only open until 6:00. So i went to the Zone and got what i paid for. Thanks, B&B. I just about got it ready for plowing.prsport
  13. cubicinches

    cubicinches PlowSite.com Addict
    Messages: 1,412

    Ahh... Gotta love the vacuum pressure. ;)
  14. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    He never mentioned that it wasn't a boosted application. :D