1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

As If!

Discussion in 'Truck & Equipment Repair' started by repo_man62, Dec 9, 2006.

  1. repo_man62

    repo_man62 Senior Member
    Messages: 502

    Went out to start the 'burb today. Started right up.But....when I went to turn it around for better access...NO POWER STEERING!:angry: Checked fluid...fine...loosened return and pressure lines...no air...rev up engine...POWER STEERING! WTF?? I looked for another pump on E-bay...no luck! Any ideas?(Don't tell me to buy a ford!):nono:
     
    Last edited: Dec 9, 2006
  2. streetsurfin'

    streetsurfin' Senior Member
    Messages: 770

    How about maybe some moisture frozen up in there and it took a few seconds for it to thaw or break loose? I don't know - just a guess. I had a toyota p/u once that would kind of airlock after a quick movement of the wheel and get all jiggety on me for a few seconds.
     
  3. repo_man62

    repo_man62 Senior Member
    Messages: 502

    Even after driving it and letting it warm up...the only way it turned easy was on snow or if RPM's were up. IF there WAS anything frozen..let's see...that would have blew out when I screwed up and took the return line off when it was running! (Another brain fart)
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Sounds like the pressure relief valve is stuck in the pump.Or the spring behind the valve is weak. Dont waste your time with an ebay pump as you dont know what your getting.Just head down to your local parts store and grab a reman pump,there not expensive at all,just bought one on monday for an 85' K-20 (basically the same pump as your Sub would have) cost was $38.00. Make sure to flush the system out when you replace it.
     
  5. repo_man62

    repo_man62 Senior Member
    Messages: 502

    O.K. ...thanks for the info.
     
  6. MickiRig1

    MickiRig1 PlowSite Veteran
    Messages: 3,617

    If you change the pump make sure you get the plastic O rings on the lines back up the threads so you don't cut them when you put the line on. They tend to come off with the line. Then you have a high pressure leak later on. High pressure fluid sprayed on an exhaust manifold will quickly catch fire.
     
  7. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Fortunately,the GM's don't use the plastic O-rings on the hoses like the Ford's do.And i'm glad as your right Micki, those plastic ring's can be a real pain in the butt! :D
     
  8. repo_man62

    repo_man62 Senior Member
    Messages: 502

    Not looking forward to this! Was told I have to take the Alternator & bracket COMPLETELY off so I can get the pump off enough to pull the pulley off!:angry: THEN change the pump. Guess the pully shaft sticks out too far to just slide back out of the bracket without hitting the block. AND there's a bolt RIGHT behind the res.
     
    Last edited: Dec 9, 2006
  9. Robhollar

    Robhollar Senior Member
    Messages: 766

    "Not looking forward to this! Was told I have to take the Alternator & bracket COMPLETELY off so I can get the pump off enough to pull the pulley off! THEN change the pump. Guess the pully shaft sticks out too far to just slide back out of the bracket without hitting the block. AND there's a bolt RIGHT behind the res."

    Not true, what we usually do is to take all of the bolts that you can, there will be one bolt on the lower part of the bracket that you will not be able to get out easly, so what we do is to pull the bracket towards the front of the truck. This should give you just enough room to remove the pump....Rob