1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

artic hydraulic wiring

Discussion in 'Arctic Sectional Sno-Pusher' started by rick54, Jan 4, 2007.

  1. rick54

    rick54 Junior Member
    from bc
    Messages: 7

    Help! New to the site, rick54, I have an older artic unit 1960 to 1970 so I've been told. had it repaired was working fine then failed. My son tried to help rewired it - now it only goes up . Has a new pump and three new solonoids.Please help.Does anyone have a wiring diagram. email address ricksrockworks@yahoo.com
     
  2. DAFFMOBILEWASH

    DAFFMOBILEWASH PlowSite.com Addict
    Messages: 1,597

    Test Light A Must

    Well I don't know where to find a wire diagram but I have an idea.

    a: Check for power at coil packs (3)?
    b: If each pack has voltage try to figure out the one for up down.
    c: swich other two.
    d: If no power at coil pack try at toggle swich
    e: No power from swich replace
    f: check for magnetic charge from packs when voltage is applied.
    g:are you getting any closer?

    Keep in mind I am not sure on what this pump really looks like. I've worked on arctic and meyers plus fisher in the past and they all use the same general wiring principals. Good luck in yur quest. If you still can't get it to work try giving a little more info one the pump ect.

    DAFF:)
     
  3. real snowman

    real snowman Junior Member
    Messages: 12

    :drinkup:do you still need help.I have pump and wiring and troubleshooting guides.
     
  4. rick54

    rick54 Junior Member
    from bc
    Messages: 7

    artic unit horizontal

    probably 70's
    I've had this pump
    fixed twice last two years
    Last year had new pump put in
    and two new coils.
    This year all that is happening is
    i hear motor turning but no hydraulics
    won't lift, no right angle,no left angle,
    Please help stuck in the snow.


    Yours Truly Rick
     
  5. rick54

    rick54 Junior Member
    from bc
    Messages: 7

    rick54

    rick54-to real snowman I sure could use the wiring diagram.
    Its got new wiring, I've checked ground,Motor turns thats all.
    With hoses hooked up .I can manualy push angle blade left to right:bluebounc:bluebounc:angry:
    with no resistance. what do you think?
    I haven't tried a new solonoid yet that will be next and its still snowing out.
    I'm getting shorter

    rick54:
     
  6. rick54

    rick54 Junior Member
    from bc
    Messages: 7

    rick54 artiic wiring and pump problems

    Hi! guys - Found ploblems with artic pump unit.
    Pays to keep trying.As i said was rebuilt last two years.
    Just kept triying left to right angles and up and down.
    Started working on its own . I think water got into pump somehow,
    Weather warmed up a bit.Fluid in pump was milky white(dextron 111).
    Questin its an old pump 70's does not have any kind of air breather.
    Could that of contributed to moisture problem?
    I've flushed fluid out.I'm going to try another kind of fluid is that a good ideal or bad one.
    Ive got extra fluid that i use in my backhoe.

    thanks rick54:waving:
     
  7. real snowman

    real snowman Junior Member
    Messages: 12

    Hey Rick, sorry been away for a while. Send me an e-mail to theconsoli3@hotmail.com and I will send you the info. I am currently having the same problems. Plow will go up and down. No side to side. I can manually push plow side to side no problem manually.
     
  8. real snowman

    real snowman Junior Member
    Messages: 12