1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Arctic Plow Worked Fine then stopped going up and side to side

Discussion in 'Truck & Equipment Repair' started by timanderson, Jan 29, 2009.

  1. timanderson

    timanderson Junior Member
    Messages: 2

    My 2008 8ft arctic plow worked fine last night during the snow storm and fine this morning when i went out to pay bills. On the drive home was bored so went to play with the plow and it wont go side to side or up.
    the motor makes a sound but no movement
    as soon as i got home i checked the fluid level and topped it up but was really not alot needed
    please help thanks
    Tim
     
  2. 04sd

    04sd Senior Member
    from pa
    Messages: 266

    No idea what kind of pump you have but...
    - are the solenoids on the pump getting power when you hit the control?
    - is it frozen up, water in the oil? pull it in a heated garage and see if it works after it warms up.
     
  3. timanderson

    timanderson Junior Member
    Messages: 2

    yes the solenoid is getting power, and no its not frozen up was working fine while i was driving around town then just stopped
    thanks tim
     
  4. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    i bet it froze up while you were just driving around. bet