1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

anyone have this problem?

Discussion in 'Boss Plows Discussion' started by GA73, Jan 5, 2011.

  1. GA73

    GA73 Member
    Messages: 90

    after taking the spare truck in for a couple of blown brake lines and finding out it needs a $600 abs module/pump :mad: anyway come home and get ready for work go to take the plow off the big truck and find this
    anyone else have this happen?

    IMG_0513.jpg

    IMG_0512.jpg
     
  2. secret_weapon

    secret_weapon Senior Member
    Messages: 437

    That's a big tin a M&M's!

    Probably could be welded back on, but I would go to the dealer and buy the center push bar.
    You don't need to get the whole mount, just the center piece. That sucks though, looks like a fresh break.
    Was that on the spare truck that just got fixed or the other truck the plow was on? Hopefully not the spare truck. If it was I'd be thinking they bent it somehow and tried to bend it back and weakened the welds.
     
  3. theplowmeister

    theplowmeister 2000 Club Member
    from MA
    Messages: 2,552

    looks to mi like its been cracked the rust on the broken end
     
  4. GA73

    GA73 Member
    Messages: 90

    the rusty area is smooth cut looks like no weld there


    this was on my primary truck. we got up to 2 ft coming in the next few days.
    just gonna go get a new push bar in the morning
     
  5. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    My boss had that happen a few years back.