1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

anyone had this happen?

Discussion in 'Commercial Snow Removal' started by crazymike, Feb 6, 2006.

  1. crazymike

    crazymike Senior Member
    from Toronto
    Messages: 639

    I was driving down the highway the other day and I heard a clunk, and then saw a blue thing spit out the back of my truck. I couldn't think of anything blue that I had in my bed so I figured I just ran something over on the highway.

    Later on I was plowing, went inside and got my money, then went back out. I looked to see if my light was on, and it was gone :/

    I "had" a starbrite magnet mount roof strobe, blue. It had been on the truck all winter, the only time I take it off is to clean under it. Which I do often. It was also in the middle of the roof, next to my CB antenna. The magnet appearingly just failed.

    This could have injured someone had I been in heavy traffic, or scratched my truck. I'm kind of mad as they arn't cheap. But the place I got it from is far away.

    Has anyone delt with the company directly? Is it worth my while to send an email or phone them?

    It was a star warning systems. Thanks, Mike
     
    Last edited: Feb 6, 2006
  2. 84deisel

    84deisel Senior Member
    Messages: 696

    If you look at any owners manuel for any magnetic light ,it will say they should not be on the vehicle when used at highway speeds as they are only rated to 50 mph .
     
  3. derekbroerse

    derekbroerse 2000 Club Member
    Messages: 2,377

    I have two Star rotator mini lightbars... never a problem with them regardless of speed. But they have four individual magnets on them, I guess about 1.5" diameter. Probably more stable?

    They sell cheap on ebay... have a look there for a replacement. I think my 18" rotator bar was about $120.
     
  4. crazymike

    crazymike Senior Member
    from Toronto
    Messages: 639

    I sent an email to the company asking about magnet failure and road speeds. I have 3 more in use which I will remove if they arn't safe.

    By highway, I mean 80kmh highway. Just a back highway, And it was snowing, so I wasn't even doing that.

    However, I succesfully left it on all winter at highweed speeds for several months.

    When I get a new one I will permantly mount it. But it sucks having to spend another $120 after already spending that for one this year.
     
  5. welded wrenches

    welded wrenches Senior Member
    Messages: 177

    H.D. magnets Freebies

    Hi all, Usefull tid bit.My lie also un-glued itself also..ERRR i fixed it. ..useing a pair matching magnets out of junk microwave oven. 2 very strong magnets in every broken,busted,worn-out microwave oven.**sand paper one side of magnet with 80 grit sand paper and use J.B. WELD on the sanded side and attached bottom edge of strobe-rotator light** ***rusted bolts?? try used tranny fluid.** Welded wrenched :redbounce :redbounce
     
  6. crazymike

    crazymike Senior Member
    from Toronto
    Messages: 639

    unfortunately mine is lying somewhere smashed in a ditch.

    Next time, I will sand the magnet and GLUE IT TO MY TRUCK :p