1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Any problems w/A300 for Plowing?

Discussion in 'Commercial Snow Removal' started by millsaps118, Jul 1, 2011.

  1. millsaps118

    millsaps118 Senior Member
    Messages: 694

    Sounds like you guys who run these like how they perform in the white stuff. I just bought a 2002 with 5K hrs and was curious if snow/ice pack in the rear steering components becomes an issue? Do you have to clear off any snow/ice pack after a plowing event so it doesn't freeze? I've run a T190 in snow and after every use it was mandatory to clear off the sprockets, tracks and boogies other wise it would all freeze. Is this necessary with the A300?
     
  2. SNOWLORD

    SNOWLORD Senior Member
    from MN
    Messages: 610

    I have never owned one but I would assume you put it in skid mode for snow then it would be no different than an S300 which I do own and are very good for plowing.
     
  3. snocrete

    snocrete Banned
    Messages: 2,862

    I've never had any major problems with snow pack on any of my machines. Mud is what you dont want packed in...that can be a nightmare if not cleaned off before a freeze.

    I havent ran an A300 for snow work, but have read lots of reviews that the all wheel steer mode is very beneficial for snow work.
     
  4. millsaps118

    millsaps118 Senior Member
    Messages: 694

    I'm looking forward to plowing with this machine, I've read reviews about the AWS that go both ways when it comes to snow. More ppl seem to like it though.......