1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Another Uni Mount lighting question

Discussion in 'Western Plows Discussion' started by Nashotah7, Jan 8, 2016.

  1. Nashotah7

    Nashotah7 Junior Member
    Messages: 4

    Need help from all you lighting gurus out there. Here is the story, watch ya think is the problem. Pulled a uni mount off a '92 f250 and installed on a '96 F150 (bosses great idea), anyways, everything works but the lights. Bought two new relays (9 pin harness), same problem. Bought new plugs for harness, both sides, same problem. Downloaded wiring diagram from Western, everything where it needs to be. Problem; When we plug in lights don't switch from truck to plow. Swapped orange and black wires on high beam relay and get plow lights, but does not go back to vehicle lights when we unplug. Have to swap the wires again at the relay. What are we missing?:dizzy:
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,926

    Do the relays even click when you plug in the plow?
     
  3. Western1

    Western1 Senior Member
    from MI.
    Messages: 674

    I'm guessing you don't have high or low beams?
    Check for power brown wire at relays and ground black orange wire at relays.
     
  4. mishnick

    mishnick 2000 Club Member
    Messages: 2,243

    If both the source and the target truck have the same headlights and wiring then it should have just moved over no problem. There are so many different configurations for these old relay setups. It's just a matter of checking the wiring one connection at a time and verify they are correct.
    I know it's expensive but if you can't get it sorted out consider upgrading it to a three plug, three port isolation module system. It means all new wiring on both the plow and the truck but they are simple and reliable.
     
  5. Nashotah7

    Nashotah7 Junior Member
    Messages: 4

    Update: Had the truck out last night with plow attached. Went to switch from low beam to high and the plow lights went out and the truck high beams came on. According to Westerns diagram all wires are where they should be.:help:
     
  6. mishnick

    mishnick 2000 Club Member
    Messages: 2,243

    Are you sure you are looking at the correct schematic? If so then either you have a bad wire or faulty relay.
    Are you looking at the schematics guide? If so what page? Or which mechanic's guide? How many relays?
     
  7. Western1

    Western1 Senior Member
    from MI.
    Messages: 674

    Because of the trucks that are listed they would be the same headlight and would have 2 headlight relays one for high and one for low.
     
  8. Western1

    Western1 Senior Member
    from MI.
    Messages: 674

    If the low beams work you could try switching the relays to see if it just the relay.