1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Another Headlight Issue. No left side low beam

Discussion in 'Western Plows Discussion' started by cattech05, Dec 22, 2013.

  1. cattech05

    cattech05 Junior Member
    Messages: 4

    Bought a brand new MPV Plus 8.5' plow and putting on a 2004 Chevy 2500 D. Got everything hooked up to the truck. Had the light issue and swapped around from A side to B side and finally was able to get all of the lights to work as they should. (With the help of this site!!) Daytime running lights are hooked up. Took the truck for a drive. Turned it on and off a few times and now all of a sudden I have lost my left side low beam on the plow. The light stays on on the truck and does not transfer over to the snow plow. I have both high side lights without any problems. When I turn on my high beams both lights on the truck go off as they should. Everything works on the plow fine. However I did loose all power to the plow once any nothing worked. Tightened up all of the connections checked everything and worked fine except for the left side low beam. I am leaning towards the ISO module but don't know how to test it. I have the 3 port ISO module. Any suggestions?
     
  2. mishnick

    mishnick 2000 Club Member
    Messages: 2,243

    Sounds to me like the ISO mod is loosing its activation signal from the truck headlight plug. The ISO mod is recognizing the presence of the plow or the hyd functions would not work. Check behind the headlights and make sure your plugs to the western headlight harness r firmly connected.
     
  3. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,946

    Make sure you ck pwr in and out first before you condemn the ISO. If you lost pwr once and you said you tightened everything up and it worked again. Start there. Ck you headlight connectors
     
  4. cattech05

    cattech05 Junior Member
    Messages: 4

    How can i check for power in and out at the iso? I did check all of the connections. All are tight and good. If i am getting power in and the light is not turning off and switching over to the plow is it the iso then?
     
  5. cattech05

    cattech05 Junior Member
    Messages: 4

    Also wanted to add that if i switch the high and low side plugs at the headlight i get both low beams then i lose my left side high beam.
     
  6. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,946

    Well start at the headlight connections and prob all the wires both sides of the connectors. Then go up the the ISO and ck pwr and gnd in and then pwr and gnd out
     
  7. cattech05

    cattech05 Junior Member
    Messages: 4

    Got it figured out finally! Got extemely busy and never got back to it. It was the ISO Module. Thanks for all of your help!!!