1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

am i wasting my time?

Discussion in 'Ford Trucks' started by snowplower1, Mar 3, 2015.

  1. snowplower1

    snowplower1 Senior Member
    Messages: 752

    I am gonna have ford look at my 2015 as it is having the same problem many are having with the fact that the fans and electronics on the dash all shut off randomly when raising the plow. will they actually be able to do anything or is there still no fix to this issue?
  2. Antlerart06

    Antlerart06 PlowSite Veteran
    Messages: 3,437

    See I haven't seen that problem.
    What kind of 2015 Ford is it ???????

    My 15 Chassis F350 with 6.2 never seen it with the plow or the Hoist bed
    The 15 chassis F350 6.2 farm truck never seen that issue either and it has a bale bed on it and lifts 1500lb bales with no issue.
    Both has the plow package with big Alt. Mine only running one battery.

    But I'm watching them close. So if you find out what it is. Post it
  3. snowplower1

    snowplower1 Senior Member
    Messages: 752

    that really confuses me then because i have a 2015 f-350 xl and have plow prep with big alt in it and running one battery. The only reason i am really bringing it in is that i paid for a plow prep and obviously it is not prepped for plowing so i figure its on them i hope. if they find anything ill update you. I do know many people posted about this a month or so back that is why i ask cause i have heard of no solutions
  4. grandview

    grandview PlowSite Fanatic
    Messages: 14,609

    No problem with mine.Lights heater plow
  5. Mark Oomkes

    Mark Oomkes PlowSite Fanatic
    Messages: 10,477

    Sorry to hear that.

    When I bought my '05 I couldn't go 5 MPH without it overheating. Added the plow prep fan and it was fine.

    Bought a '14 Ram out of California with a cold weather kit. Doesn't come close to overheating.

    Hope they get it figured out.
  6. snowplower1

    snowplower1 Senior Member
    Messages: 752

    It's not a huge issue but when you buy a 40k truck you want it to be flawless regardless of how small of an issue it is...
  7. Mark Oomkes

    Mark Oomkes PlowSite Fanatic
    Messages: 10,477

    I agree, I do have a couple issues with mine that I need to be taken care of.
  8. tjctransport

    tjctransport PlowSite.com Addict
    Messages: 1,390

    we have three of them in work, an 11, a 13, and a 15. the 11 and 13's are F-550's the 15 is a F350. no electrical problems with any of them except for bad batteries in the 550's that ford replaced for free, but they are diesels too.
  9. lawnboy2121

    lawnboy2121 Senior Member
    Messages: 467

    Doesn't fisher or Douglas dynamics have a bulletin out on this problem
  10. 1olddogtwo

    1olddogtwo PlowSite Fanatic
    Messages: 11,395

    Yea, its affecting ford and GMs that have plow package.
  11. LapeerLandscape

    LapeerLandscape PlowSite.com Addict
    Messages: 1,465

    My chevy with my MVP plus does it occasionally more often with the fan on high. The dash and gauges all go dead and come right back up.
  12. blueline38

    blueline38 Senior Member
    Messages: 436

    I had a 2011 F250 with the 6.2 and I had no problems with the plow. I also had the plow prep package. I don't even remember my lights dimming.
  13. I RocDuP I

    I RocDuP I Member
    Messages: 40

    My 2015 will do it occasionally. Like the bulletin states its more LIKELY to happen when you have a very LITTLE electrical load on the truck. When I have my headlights on, heater, radio, alot of electronics running the lights on the dash will never go out. Let me know what ford says, yet to bring mine in yet
  14. snowplower1

    snowplower1 Senior Member
    Messages: 752

    It ended up snowing that morning and was just too tired and busy to go in. I will bring it in sometime, not in a huge hurry
  15. F250/XLS

    F250/XLS Senior Member
    from Canada
    Messages: 142

    Who made thé installation of thé plow
  16. snowplower1

    snowplower1 Senior Member
    Messages: 752

    My boss dealer, Its not an issue of the plow. If you search here, you will see a bunch of pepole have had this issue on chevy and ford, not sure about ram.
  17. snowplower1

    snowplower1 Senior Member
    Messages: 752

    and my boss dealer is general welding, they have been great to deal with and done great work in our equipment
  18. wadadlianu

    wadadlianu Junior Member
    from NH
    Messages: 7

    I have driven 2012 - 2015 F250 and 350 and none have ever shown these issues with a Boss or Fisher plow. When I see some complain about this issue, I wonder if there are installation issues
  19. F250/XLS

    F250/XLS Senior Member
    from Canada
    Messages: 142

    Its exactly What i was saying its to easy
    to miss something,,,
  20. snowplower1

    snowplower1 Senior Member
    Messages: 752

    maybe i will talk to my dealer and see if he thinks it could be possible it has anything to do with the installation. I personally just think it has something to do with the truck not being able to produce enough power even though it has the extra hd alt. I could see that maybe its the plow that is drawing too much power.

    The hardest part is its not like it does it a lot and you have no idea it will do it. It also only does it for a second so its hard to figure it out.