1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

alternator issue?

Discussion in 'Ram Trucks' started by dave_dj1, Dec 26, 2012.

  1. dave_dj1

    dave_dj1 Senior Member
    from NY
    Messages: 350

    I have a 2010 Dodge Ram that has a plow prep package including a 200 amp alternator The problem is when I have the headlights on and angle my plow (Meyer C8 with an E60H pump) the radio gets knocked out for a second, it comes right back on but it doesn't do it when the lights are off. It doesn't bother the radio lifting the plow. Any ideas?
    I am thinking about adding a second battery to maybe help things.
    thanks,
    dave
     
  2. dave_dj1

    dave_dj1 Senior Member
    from NY
    Messages: 350

    Well I gave it a pretty good workout with today's storm and didn't have any issues other than an occasional outing of the radio. I ran the blower, lights, Whelen 9000 lightbar , radio and wipers and had no other issues so I guess I'm good to go.
    Now I gotta rig up some back up lights.:mechanic:
     
  3. ringahding1

    ringahding1 Senior Member
    Messages: 260

    Man that same thing was happening to my 08' 250. Only when it was cold, after awhile would not do it anymore.
     
  4. Mark Witcher

    Mark Witcher Senior Member
    Messages: 604

    The power wire for the plow is probably piggy backed to the radio fuse.
     
  5. dave_dj1

    dave_dj1 Senior Member
    from NY
    Messages: 350

    That's a thought. I'll check into it as soon as it warms up a bit.