1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

all i get is a click

Discussion in 'Fisher Engineering Discussion' started by redsoxfan, Jan 12, 2011.

  1. redsoxfan

    redsoxfan Senior Member
    Messages: 102

    I have a mm1 electric over hydraulic 3 plug when I go to move the plow all I get is a click at the slinoid thought it was the motor went out b bought a new motor installed it and no luck and I changed the slienoid under the hood . Anyone have any idea on what else it could be any help would be great thank u . Still getting power cause the box still turns on
     
  2. Jaspell

    Jaspell Member
    from 06117
    Messages: 60

    Sounds like a bad solenoid to me.
     
  3. redsoxfan

    redsoxfan Senior Member
    Messages: 102

    In the plow or under the hood ?
     
  4. mrv8outboard

    mrv8outboard Senior Member
    Messages: 197

    Using a test light, check for power at the solenoid (power on one lug B+ ) now activate the solenoid and test the other lug for B+. (These should be ok if you hear the solenoid activate.) Here is where you might find the problem, hook the test light to the B+ battery terminal and test to the ground (B- lug) on the motor. One of these two leads and or connections are bad.