1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

ABS light on

Discussion in 'Chevy Trucks' started by mkwl, Dec 24, 2008.

  1. mkwl

    mkwl 2000 Club Member
    Messages: 2,361

    Went out to my truck this AM- started the truck and the ABS light stayed on. Any thoughts? Just had the whole hub assembly changed with the ABS on that hub as well- anyone think it could be this? Anyone had this problem?
  2. fordmstng66

    fordmstng66 Senior Member
    Messages: 527

    I do not know if they fixed it, but the 2000 had problems with the sensor in the hub. Did your new hub assembly have the abs sensor in it? They so sell the hubs with and without the abs sensor i believe. If it did not, they probably just used the old one, and it could be dirty. That is just my .02 hope you fix the problem.
  3. Spitz

    Spitz Senior Member
    Messages: 192

    You're going to need to pull the code.. I would first just look at the connector for the side they put the hub on and make sure its fully seated first, and then see if the light goes out, if not, you're gunna have to get the code for further diagnosis.
  4. mkwl

    mkwl 2000 Club Member
    Messages: 2,361

    Took it up there- plugged it in- no code thrown :confused: They replaced the whole assembly- including he sensor- maybe a defective sensor in the hub? Not sure if it matters- but it's VERY humid and rainy out today- only did it this morning- not when it was dry out. Tried resetting the comp and re-plugging it in- no luck. :cry:
  5. RichG53

    RichG53 PlowSite.com Addict
    Messages: 1,135

    Take it back you paid to have it fixed..
  6. Scott13136

    Scott13136 Member
    Messages: 53

    Mine comes on if i sping the tires to much, It clears itself eventually (02 2500hd)
  7. Tango

    Tango Senior Member
    Messages: 205

    Mine does the same thing.
  8. brad96z28

    brad96z28 PlowSite.com Addict
    Messages: 1,526

    If the light is on it has a code for sure.
  9. mkwl

    mkwl 2000 Club Member
    Messages: 2,361

    This is the damndest thing- light came on again today- truck was sitting in the parking lot all day (not driven), hop in, and the amber ABS light is on :confused: It was pouring rain all day, and very humid- same conditions as the light coming on before- maybe a bad ground somewhere?
  10. naturalgreen

    naturalgreen Senior Member
    Messages: 404

    sounds like maybe something grounding or arcing when wet
  11. mkwl

    mkwl 2000 Club Member
    Messages: 2,361

    That's what I'm thinking- problem is, all the grounds "look" okay- I'll have to dig deeper...
  12. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    They can "look" good all day long Matt..you have to physically remove them and clean them to know that they're truly good.

    Don't forget the one under the driver door...there's three there and one of them is for the ABS unit. ;)
  13. mkwl

    mkwl 2000 Club Member
    Messages: 2,361

    Makes sense- will look into this next time I'm home (the college police prohibit us for working on ANYTHING on vehicles on college property)- I assume then that it's possible for the moisture/rain to cause it to have a "bad" ground, but then it dries out and it's okay again?
  14. Newdude

    Newdude Senior Member
    Messages: 877

    Dumb question...is the abs sensor plugged in? Maybe the guy who fixed it forgot? Maybe the wires got pinched?
  15. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Anythings possible Matt. A poor ground, a pulled wire causing an intermittent open connection at the wheel sensors etc. So you need to inspect and check them all.

    Also, is it only the orange ABS light that illuminates or does the red brake light icon also light at the same time? Just checking, as there's TSB for that that has nothing to do with wiring, it's for a re-flash of the ABS unit. Plagued the '03 and 04 trucks for a few years after they were out. :nod:
  16. Gregg1987

    Gregg1987 Member
    from NY
    Messages: 32

    What would cause both the ABS (orange) and Break light (red) to go on at the same time? Is that a huge issue?

    i have an 01 3500 Duramax and they said that they were on previously but the issue was resolved before i saw the truck. (haven't seen the lights since i had it but they said that they were lit at one point) Seems fixed just curious what that would have been? Serious problem?
    Last edited: Oct 27, 2009
  17. mkwl

    mkwl 2000 Club Member
    Messages: 2,361

    Over the summer it was coming on with both the red and amber lights. That issue "resolved itself." and I was good until the weekend.

    This most recent time, just the amber ABS light was on- now it's off again.
  18. mkwl

    mkwl 2000 Club Member
    Messages: 2,361

    When I had it scanned over the summer the code came up as "no communication with the EBCM" then it went away :confused:
  19. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    It needs the EBCM reflashed with the newest software version. That was a common issue with the '03-'04 models were when you started the truck the body control module didn't wait long enough before checking for the "a ok" power up from the EBCM. When it doesn't receive the ok signal in time they illuminate the brake icons and set the specific code you found. There's a TSB on it and it's an easy fix. Bulletin # is: 04-05-25-006A

    You still have a wheel sensor issue too that isn't related to this so be sure to still check over your grounds and sensors like I mentioned before.
  20. mkwl

    mkwl 2000 Club Member
    Messages: 2,361

    Thanks B&B- any idea how much the "flash" costs? It also seems to be very related to the moisture/rain (comes on when it's "wet" outside).