1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

a frame latch problems

Discussion in 'Blizzard Plows Discussion' started by james1115, Jan 14, 2010.

  1. james1115

    james1115 Member
    from CT
    Messages: 81

    I have a 2002 810 and the a frame latch seems to have a mind of its own. sometimes I pull right in my garage and it comes right off after plowing and other times it is bound up and wont budge. When it does this I take out a hammer and hit the latch while I try and disconnect it. sometimes it works sometimes it doesnt. when it doesnt I leave it and take a break and sometimes i will come back 5 minutes later and it comes right off first time and sometimes it doesnt. It really makes no sense at all! I am so fed up with it but I can't figure out what the problem is because it is so spuratic. Please help me out.
     
  2. lilweeds

    lilweeds PlowSite.com Addict
    Messages: 1,178

    Are you using the switch on the plow to take it off? Cause that is what it's there for.
     
  3. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,169

    Sometimes you need to adjust the nut on the claw. Either tighten or loosen. Blizzard also has excellent tech support on their website.
     
  4. babs2972

    babs2972 Junior Member
    Messages: 23

    I just had this happen to me this week. there are a few things to look at. 1.your electric coil labled s8. The valve under the coil. Or the A-frame toggle switch. do you know how to test the coil?
     
  5. james1115

    james1115 Member
    from CT
    Messages: 81

    ok rsvees are you serious?????? ......... I am not a moron!
    Mr I will look into tightening the nut on the claw.
    also babs I will test the coil, isnt s8 a selinoid? I replaced my toggle switch today and still had the same problem so I guess its onto the nut and the coil and a little bit of praying because this is getting highly annoying lol
     
  6. babs2972

    babs2972 Junior Member
    Messages: 23

    Yes s8 is a coil solenoid but in the parts world i guess they are calling it a coil. I found that out the hard way when i ordered one for $62 and they sent me the heavy duty one that goes in the truck engine compartment attached to the battery. Even after giving them the part number to s8. This is what i did....take off s8 and s10. s10 is for the driver side wing extend. put s10 on the valve s8 came off and tighten nut. go in the cab to the plow control and switch from power hitch operation to plow control. Then push the button or joystick (whatever you have to drop the plow to float so it will open the s5 valve) and push the driverside wing extend at the same time. Listen for the pump motor, when you hear it working wait till it changes tone so you know the draw latch has dropped all the way. If this works then your s8 coil is bad and your valve is not clogged. If this dose not work then your valve is probably clogged. doing it this way lets you test both the coil and the valve without cutting wires. You can test the coil by taking off s8 and putting a nail or metal screw driver on the coil and pushing toggle down,the coil should magnetize.good luck,let us know what happen. Mine was, after all that, the toggle switch was bad in the down posission only.
     
  7. voyagerxii

    voyagerxii Junior Member
    Messages: 12

    I'm a little confused. This is really about the draw latch, not the A-frame latch, right?

    Scott
     
  8. babs2972

    babs2972 Junior Member
    Messages: 23

    James1115..... did you fix your plow?? what was wrong ? how did you fix it?
     
  9. james1115

    james1115 Member
    from CT
    Messages: 81

    Hey Babs, so I replaced my toggle switch and thats not it. I checked all the selinoids and they are all good. The next step is to switch the valves to see if its a clogged valve. If its not that I am lost lol!!!!! I am gonna try to get a look at it tomorrow but I have been busy working on my truck. I will let you know!!!! thanks for all the help I really appreciate it.
     
  10. babs2972

    babs2972 Junior Member
    Messages: 23

    working on your truck!!?? it must be a chevy!!:laughing: well good luck and let us know if you fix it
     
  11. james1115

    james1115 Member
    from CT
    Messages: 81

    nope its a Dodge! I had to do a new power steering pump, new rotors and brakes, new abs sensor( broke when doing new ball joints and tie rods), new serp belt and alternator, and changed all the fluids. I am planning on getting around to the plow tomorrow. I will let you know what happens.
     
  12. james1115

    james1115 Member
    from CT
    Messages: 81

    alright Babs so I finally got around to the plow. I installed a new switch and that didnt work so I decided to drain the fluid. I noticed that it was milky in the manifold so I drained it all. I put in fresh fluid an d wow what a difference:) I took out all of the valves and cleaned them up and blew them out with a airhose. put everything back together and it is like a brand new plow. I am psyched it moves so much better and faster, the motor is much quieter and it doesnt kill my alternator nearly as bad as it did before. Also the A-frme latch has worked everytime without fail:)