1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

9ft2 v plow doesnt work!!! please help!

Discussion in 'Boss Plows Discussion' started by F250 9ft2V, Sep 9, 2009.

  1. F250 9ft2V

    F250 9ft2V Junior Member
    from mn
    Messages: 1

    I just bought a 2001 f250 and this plow last spring and used it twice. I just went to hook it up a week ago and was in the float mode, i when to the toggle switch and the pump or something screached real bad so i wiggled the switch the back and forth and it kept doing it without the plow pulling up and then finally the noise just quiet. So here we go i checked all the fuses inside the fuse panel and under the hood, nothing, everything is ohming out and no blown fuses. I have power at the controller and when you plug it in it lights up and the solinoids click you can here them working but no pump motor. So i go to the coil that closes to energize and send power to the pump motor, No power incoming to the coil, so I know thats why it wont work. Heres the deal I just dont know enough about plows being this is my first one so if anyone has any ideas or knows what or where sends power to the solinoid coil I would really appriecate it. Oh and one more thing, if I hot wire the plow it works perfert but im sure this is not good the the pump motor.
    By the way the guy I bought it from swears it ran perfect before I got it. Ahhhhhhhhh BS
    Thanks
    Very expensive lawn orniment
     
  2. SteveR

    SteveR Senior Member
    Messages: 252

    The noise indicates to me that you had something in the pump or motor binding. I would bet when you kept trying you either blew a fuse somewhere or burnt something electrical.