1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

99 Silverado

Discussion in 'Truck & Equipment Repair' started by naturalgrass, Dec 15, 2009.

  1. naturalgrass

    naturalgrass Junior Member
    Messages: 9

    Four wheel drive (push button) won't engage. The light stays on "2 hi". Auto 4wd, Hi 4wd and lo 4wd won't engage when I push the buttons. I put the truck in neutral when I try to go to 4hi or 4low....HELP!:dizzy:
  2. gc3

    gc3 Senior Member
    Messages: 713

    Mine used to do that but when it did I could turn the truck off then back on and it would work. I ended up replacing the 4wd module that your trying to push. It was around 1000 but it was under the warranty.
  3. ahoron

    ahoron Senior Member
    from here
    Messages: 422

    does it click when you put it into 4x4?
  4. naturalgrass

    naturalgrass Junior Member
    Messages: 9

    No....no sound at all.
  5. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    When you press the 4HI button (going from 2HI) does it at least blink until it times out?
  6. snow7899

    snow7899 Senior Member
    Messages: 238

    Take a look inside the switch, we had a few with bad solder joints on the cicuit boards. Instead of replacing switch we resoldered it and works great.
  7. naturalgrass

    naturalgrass Junior Member
    Messages: 9

    Doesn't blink at all...in fact, the other buttons do not light up at all. Sometimes when I push the other buttons, the light in 2hi will go out. Then it will come back on after I let off the other buttons.

    I'm going to pull out the switch and look at the soder joints.

    Thanks for your help guys....keep it coming!
  8. jgsxr750

    jgsxr750 Member
    Messages: 84

    if you need to order new switch go to Gmpartsdirect.com to order the parts. Alot cheaper than local dealer parts. Also you should check your encoder motor could be bad. My truck the light went out on the switch and i changed it and still had problem. Need to attach truck to a good code reader and pull the codes it's spitting out and go from there. sounds like encodor motor to me but that's my 2 cents.
  9. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Yep, probably needs the switch assembly addressed. Super common issue on the '99-'02 trucks.
  10. leepotter

    leepotter Senior Member
    Messages: 122

    This may sound odd but disconnect ur battery for a minute or two then hook it back up and try it again. I had to do that to my Blazer.