1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

99 F250 No spark

Discussion in 'Ford Trucks' started by Bossman 92, Nov 23, 2008.

  1. Bossman 92

    Bossman 92 PlowSite.com Addict
    Messages: 1,771

    Hey guys, I have a 99 f250 with the 5.4 L and sometimes it doesn't give a spark.

    Last week I had a good friend of mine tuned up the truck and replaced the air intake gasket. It ran 100% better afterwards, but the next day he went to start it up and it wasn't getting any spark. He let it sit over night and went out the next morning and it was giving spark and started right up, and now everything appears to be fine.

    It seems like the same thing happened last year and I replaced a relay under the hood and it worked fine, but I can't be sure.

    Anyone have any ideas?????

    Bossman
     
  2. hydro_37

    hydro_37 PlowSite Veteran
    from iowa
    Messages: 3,790

    Get a code reader and have it scanned and see what codes are thrown.
     
  3. Bossman 92

    Bossman 92 PlowSite.com Addict
    Messages: 1,771

    It shows no codes!


    Bossman
     
  4. f250man

    f250man PlowSite Veteran
    Messages: 3,124

    I would check the crank sensor out. the one in my ranger went bad and I had no spark. It may be a bad wire and that is why there is no codes. Just my 2 cents.