1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

99 Dodge ram 2500/ Fisher 8" storm guard 3 plug setup issue Please help!!

Discussion in 'Truck & Equipment Repair' started by allen81, Dec 23, 2013.

  1. allen81

    allen81 Member
    Messages: 97

    I need help! I have a 99 Dodge ram 2500 and only one plow light is working correctly. I have the plugs configured for my headlight setup. But when I have the lights on 1 light is dim and one light works correctly. Also my parking and turn signals are not working anymore. I have a 8" storm guard 3 plug setup. If I hook my plow up to another truck everything works fine. I have swapped out the isolation module cause was told that was the issues that didn't fix anything. Then I had the control harness swapped out and that didn't fix anything either. Then I had the long headlight harness swapped out and that didn't fix it either. I have totally given up. Has anyone had a issue like this with a dodge? To me it sounds like something is grounding out. Also when I am using my plow with wiper going and heat on when I use the plow my wiper will stop working and my battery gauge will drop and then a chime will go off saying "check guages" . This never use to happen I have a new battery. Not sure what is causing all these problems. Any suggestions will be greatly appreciated. I live in Ellington CT. If anyone thinks they can help me troubleshoot my issues please either comment, call or txt me at 860-327-2527.

    Thanks,

    Allen
     
  2. durafish

    durafish PlowSite.com Addict
    from 02919
    Messages: 1,092

    Have your cleaned the connections at the lights? I had the same problem and that fixed it.
     
  3. allen81

    allen81 Member
    Messages: 97

    Yes I have it doesn't do anything. Sounds like a short or grounding issue but I have given up on trouble shooting the problem I have been using it with 1 headlight and not park/turn lights. Knock on wood I don't get pulled over. Why would it work on another dodge perfectly fine but my truck it won't?
     
  4. durafish

    durafish PlowSite.com Addict
    from 02919
    Messages: 1,092

    Maybe your lighting harness is for a different truck? I put a 02 harness in a 98 and the exact thing happened.
     
  5. allen81

    allen81 Member
    Messages: 97

    How do I know if I have the wrong lighting harness.
     
  6. durafish

    durafish PlowSite.com Addict
    from 02919
    Messages: 1,092

    I'm just going to text you.
     
  7. allen81

    allen81 Member
    Messages: 97

    ok thanks I appreciate it.