1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

98 k2500 transfer case problem HELP!

Discussion in 'Chevy Trucks' started by golfmanres, Nov 27, 2005.

  1. golfmanres

    golfmanres Senior Member
    Messages: 150

    Hello to all... I am in need of some help... As always i turn to Plowsite..
    So I get into my truck today go about my business and i decide to push the 4x4 hi buttom. It sounds like it engages but the light just flashes:realmad: . I am in park or neutural it doesnt matter. I also smell something not normal under the truck.. I dont know what the problem is. Is it easy to fix? Has anyone else come across this problem? I really dont want to take it to the dealer if its something that i can fix. I normally do all the work on my truck so i think if i just can pin point the problem i can fix it...

    THank you for any help.

    ERIK
     
  2. I have never had that problem before, but I figured I'd drop you a tip...

    Go to ALLDATA.com, it cost like 15 bucks a year. I have had it on all my vehicles for the past 3 years and have saved so many phone calls and money at dealers. Its the same information that dealers use to repair their vehicles...
     
  3. golfmanres

    golfmanres Senior Member
    Messages: 150

    Would you be willing to look it up for me? So you have never heard of this problem... I looked in the book and it said that it would blink only if it doesnt engage but i think it is i can hear it... and it feels like it is when i drive and turn the wheel. Its the smell that bothers me first and second that the light is blinking..

    ERIK
     
  4. davidrbean

    davidrbean Member
    Messages: 49

    Where in nova are you located. I have access to alldata info and I can probably helpyou fix it if you are fairly close. Diagnostics are limited without a scanner but here is how to get some codes
    Notes

    The diagnostic trouble codes are displayed on the three transfer case shift select buttons. The shift select buttons are located on the instrument panel when the connector pin 13 on the data link cable is grounded, and the ignition switch has been OFF for at least five seconds prior to positioning the ignition switch to run the shift select buttons will blink various times together in order to indicate a diagnostic trouble code from 1 to 4.
    1.1. Position the ignition switch to OFF.
    Ensure the ignition switch is positioned to OFF for at least 6 seconds.
    1.2. Connect pin 13 on the data link cable to a vehicle ground source.
    The data link connector is located in the cab under the instrument panel on the drivers side.
    1.3. Position the ignition switch to RUN.
    1.4. Note the shift select buttons for blinking codes. Refer to Diagnostic Trouble Codes.

    If the shift select buttons all blink one time and stop, and do not continue to blink, no fault codes are stored in the TCCM.
    The transfer case shift select buttons will blink in order to identify any stored DTC. If only one code is stored in the TCCM memory, that code will blink repeatedly with a three second delay between blinking sequences. If more than one code is stored, the first code will blink once, then after a three seconds delay, the next code will blink. This sequence will continue until pin 13 is no longer grounded.
    When reading the diagnostic trouble codes, the number of shift select buttons blinks will indicate the code number.

    Hope this helps some
    dave:waving:
     
  5. golfmanres

    golfmanres Senior Member
    Messages: 150

    Hey Dave i live in Herndon and work in Fairfax. I am willing to come to you if need be.. I really dont understand what you are telling me in your post... I can go to the Dealer i have a pretty good rep there and have them look up the codes for me.. I am just looking to find out what failed if anything.... Am i am guessing you are telling me a way of checking the codes with out a code reader...

    ERIK
     
  6. davidrbean

    davidrbean Member
    Messages: 49

    you got mail call me and we can talk:waving: its easier that way
     
  7. bdavis

    bdavis Member
    Messages: 67

    I had exact problem

    I just had this problem friday....the reason is that your front actuator is bad......the transfer case engages the front driveshaft but the actuator doesn't engage the front axle.....mine did the ewxact same thing...4x4 light would just blink....so I went to the dealer and got the new replacement which comes with a new wire harness as well....installed it in a half hour and now...like new...problem solved....i got all my info on automotiveforums.com then follow link to chevy and truck....hope this helps
     
  8. fulltiltwill

    fulltiltwill Senior Member
    Messages: 204

    My 88 did the same thing. Felt like it was in 4 wheel when turning, but when I got in the mud tires wouldn't spin. The acuator is on the front differential.
     
  9. karl klein

    karl klein Senior Member
    Messages: 557

    this is a common problem withthe front acuator's on those body styles make sure that you get the updated wiring harness withthe new actuator
     
  10. golfmanres

    golfmanres Senior Member
    Messages: 150

    Does it sound right that the dealer wanted 150$ for the part and another 135 to install it. Does this sound right? he also said it could be the encoder motor... any thoughts? is the dealer trying to rip me off??

    ERIK
     
  11. neetchracer

    neetchracer Junior Member
    Messages: 26

    Being a 98, you should already have the updated actuator. I have seen them go bad, but not like the old freon style ones.

    Put the truck in 4wd and reach under and see if the front driveshaft is engaged(you may have to move forward a little), if it is, pull out the actuator and see if it goes in and out while going from 4wd to 2wd.

    $150 sounds cheap, but I have not looked at the price in a while. Your actuater just unscrews out, then screw the new one in, you should not need the new wiring harness.
     
  12. golfmanres

    golfmanres Senior Member
    Messages: 150

    Well im going to the dealer tonight to get the computer read to see what the problem is i have a 8pm est appointment i will let everyone know the out come.. I really do hope it is as easy as you guys are saying. I have 111k miles on my truck "0" major problems to date except this one now. I had a warrenty that expired at 109K miles for the full powertrain go figure. Any other things i might need to ask the dealer tonight?

    ERIK
     
  13. karl klein

    karl klein Senior Member
    Messages: 557

    here is what mine cost on a 97k2500
    p# 26060073 actuater 137.56
    p#12376317 harness 44.12
    total labore 181.68

    i was very pleased with them no problems sence and it shifts in to 4x4 better than ever you used to have to go back in forth for a little while to get it enganged know its instant. i was also very pleased becuase it broke a t 2:00am i dropped the truck off at 4:00am the security gaurd on duty opened up so i could park inside and let it melt. buy 10:00am it was fixed and back to pushing snow
     
  14. golfmanres

    golfmanres Senior Member
    Messages: 150

    Well I told you i would get back to you all... and here I sit... still with no answer. I went to the dealer and the tech at the dealer put their TECH II computer reader on and the transfer case that i have is not supported by their computer reader... Go Figure..... So i had to make an appointment for wednesday to have the whole electrical system checked out for the 4x4. They are hard pressed about selling me the Encoder Motor for some reason and not the Actuator. I think that the harness on my truck is ok because he told me that their is not a new one listed for me.

    Again for the new people lookin at this post.

    I Have a 98k2500 ext cab 5.7v8 and when i push the 4x4 button it just blinks and doesnt engage itself. I also smelt something different under the truck and it smelled like a burnt electrical motor. Well i will wait and see what other people say before i go and spend 150 on this part that the dealer doesnt think is bad.. but everyone on here is leaning towards it.... I really do think that the dealer is unsure of where to start and that they are going to test all the leads to the encoder and the actuator. I'll wait and see

    ERIK
     
  15. bdavis

    bdavis Member
    Messages: 67

    Trust Me

    buy the actuator part and take it to your local repair shop and just have them replace it...I promise that it will fix the problem......
     
  16. golfmanres

    golfmanres Senior Member
    Messages: 150

    Well i ordered the part from a Chevy dealer in Maryland i will receive it tomorrow hopefully. It only cost me 104.18 instead of 150 from the dealer down the street.

    ERIK
     
  17. golfmanres

    golfmanres Senior Member
    Messages: 150

    Please More Help!

    Well Back to square one or still at square one..... You all must of had better luck with your 4x4 systems by replacing the actuator

    Mine still doesnt work. Any More sugestions?

    ERIK
     
  18. douglasl330

    douglasl330 Senior Member
    Messages: 356

    Now just check the fuse when you have a bad one it usually blows a fuse!--Find the fuse it is probably blown replace it and your down the road unless those motors (the one the dealers all hot to replace) really go often on your year truck!:redbounce Good luck
     
  19. golfmanres

    golfmanres Senior Member
    Messages: 150

    Sorry but the fuse for the 4x4 sytem is good... I have it at the dealer and they have been researching it for the last 4 hours and cant find anything yet.. All we know is that i replaced the actuator like everyone said and it didnt fix the problem. I checked the fuse and it was fine and i disconnected the negative on the batter to rest the computer and it didnt work.

    Still you press the 4x4 hi button and it just blinks doent go into 4 wheel drive.
    I can hear something moving under the truck and i hear the box in the truck click and still get nothing

    Any more suggestions?

    ERIK
     
  20. davidrbean

    davidrbean Member
    Messages: 49

    If you want to bring it by my house this weekend and we can see if we can get to the bottom of the problem:waving: I guess you still have my number