1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

95 ram 2500 trans/stall issue

Discussion in 'Truck & Equipment Repair' started by NJ-Snowman, Feb 13, 2016.

  1. NJ-Snowman

    NJ-Snowman Junior Member
    Messages: 6

    Question For you guys out there. 1995 dodge ram 2500 4x4 5.9 gas engine stalls often when put in reverse. Issue seems to go away when truck is warmed up but stills stalls regardless. No check engine light on or rough idle starts no issues. already changed the ckp sensor and idle air control motor also changed the front motor mounts which were pretty worn out. Kinda stuck on this. :confused:
  2. rjigto4oje

    rjigto4oje PlowSite.com Addict
    Messages: 1,258

    I have the same truck well a 96 common things are coils cam and crank sensors I did just recently had a map sensor go bad. Hows fuel presure
  3. NJ-Snowman

    NJ-Snowman Junior Member
    Messages: 6

    @rjigto4oje I do not own a gauge to test fuel pressure. Plugs and wires are in good shape. I did a trans service myself new fluid and filter and saw a bit of metal shavings. Just trying rule out weather it is a motor issue or trans or both.
  4. scottr

    scottr Senior Member
    Messages: 345

    Sounds like your torque converter is locking up at idle. ( one more thing to look into)
  5. rjigto4oje

    rjigto4oje PlowSite.com Addict
    Messages: 1,258

    You need a scanner to rule a few things out and a fuel presure gauge is a must.
    When it dies does it restart right away
  6. NJ-Snowman

    NJ-Snowman Junior Member
    Messages: 6

    When it stalls i put it in neutral or park and it starts right up no issues. Because i did what i have done to it with no luck i took to a trans shop for a diagnostic service ($50) and he pointed the bad motor mounts (which i changed already) and he said trans is shot. But it does drive forward fine most of time. :alien: In all seriousness i almost want to swap the auto trans for a manual trans set up. :mechanic:
  7. rjigto4oje

    rjigto4oje PlowSite.com Addict
    Messages: 1,258

    Motors mounts may have been weak but how the heck is that going to cause a die out. If the trans is weak I would not try to plow alot with it maybe a few drives and putting in a nanual may cost you more in the lkng run unless you have a good cheap pick and pull yard
  8. NJ-Snowman

    NJ-Snowman Junior Member
    Messages: 6

    Like @scottr said about the torque converter locking up maybe thats it i am not a mechanic just very handy and willing with a decent toolbox. I hope i get some other ideas on here but i think the realistic answer is to get a used trans and put a new torque converter in it. I have done alot to this truck over the last 3 years and know my around it fairly well but this issue has me stumped.
  9. maxwellp

    maxwellp PlowSite.com Addict
    Messages: 1,112

    It only stalls when put in reverse?
  10. NJ-Snowman

    NJ-Snowman Junior Member
    Messages: 6

    Yes only when put into reverse. If you drive its fine once in a while it seems to pop out of final gear on highway but not always other then that it drive good.
  11. gman2310

    gman2310 Senior Member
    Messages: 170

    I would get a dodge remanned trans....we just did ours in our 95 2500. I bought a rebuilt trans off craigslist for $700 and paid a mechanic to put it in, needless to said trans was shot. I looked at a monster trans but reviews are all over the place. I also had Aamco done one years ago that last less than 2 years. Our 98 with a factory remann is on its 4th year with no issues. They also come with a 3 year 100k warranty, regardless of use
  12. Whiffyspark

    Whiffyspark 2000 Club Member
    from SOMD
    Messages: 2,402

    Check your fuel pressure and vacuum as well. Or pay a shop to look at it , should be able to tell if converter is locking up through scanner