1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

95 f250

Discussion in 'Truck & Equipment Repair' started by GM_Fan40, Dec 31, 2011.

  1. GM_Fan40

    GM_Fan40 Member
    Messages: 87

    My brother in-law has a 95 F250 2 wheel drive with the E40D. When your driving and the tranny shifts (especially at higher RPM'S) the darn thing shifts so hard you smack your head on the back window. He had the tranny rebuilt about a year ago and brought it back to where he had it done and they said there was no trans codes but they believe the TPS is bad. But they also said that there is 2 different TPS sensors. One being $50-100 and the other requiring the replacement of the whole pedal assembly (costing around $1000). Does this sound like it could fix the problem? And has anyone else had this problem? Thanks!
     
  2. GM_Fan40

    GM_Fan40 Member
    Messages: 87

    Sorry it has a 7.3 in it
     
  3. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,963

    do you have access to a scan tool?? watch the tp pin while pressing the pedal.
    is the motor a power stroke? or idi motor?
     
  4. GM_Fan40

    GM_Fan40 Member
    Messages: 87

    Its a powerstroke 7.3. And yes we do have access to one.
     
  5. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,963

    ok,,hook it up and watch the tps pid and see if it jumps while pressing the pedal SLOWLEY down. truck does not have to running either.
     
  6. GM_Fan40

    GM_Fan40 Member
    Messages: 87

    Ok ill check it out and let you know what i.find. Thanks for your help.
     
  7. Milwaukee

    Milwaukee 2000 Club Member
    Messages: 2,180

    Is overdrive flash? Is all brake lights work?
     
  8. GM_Fan40

    GM_Fan40 Member
    Messages: 87

    No, the overdrive light doesnt flash and all the brake lights work.
     
  9. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,963

    so what did you find so far?
     
  10. havenlax18

    havenlax18 Senior Member
    Messages: 285

    On my 95 f250 it was the yolk that caused mine to do that. My solution was $40 at the junkyard.
     
  11. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,963

    Ok. What's a yolk?
     
  12. havenlax18

    havenlax18 Senior Member
    Messages: 285

  13. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,963

    That's yoke .
     
  14. havenlax18

    havenlax18 Senior Member
    Messages: 285

    Woops I spelled it wrong.
     
  15. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,963

    Ok thought there was a new part name I wasn't aware of
     
  16. GM_Fan40

    GM_Fan40 Member
    Messages: 87

    Ran the scan tool on it and it didnt.pick.any sensors up but.coolant temp, and rpms...
     
  17. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,963

    Ok so no tps pids. Well gunna have to do it the old fashened way. Ohm meter
     
  18. GM_Fan40

    GM_Fan40 Member
    Messages: 87

    Oh joy. What all we gotta do for that.
     
  19. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,963

    Same type thing but your checking at the pedal with the meter.
     
  20. GM_Fan40

    GM_Fan40 Member
    Messages: 87

    So do do i check for resistance thru the wire, or just power thru the wire?