1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

94 Chevy Head Light Wiring Issue

Discussion in 'Boss Plows Discussion' started by surypap3, Nov 19, 2010.

  1. surypap3

    surypap3 Junior Member
    from WDC
    Messages: 3

    2008 Boss Standard duty wired to a 94 Chevy Blazer. I purchased the headlamp adapter cable. Wired the truck side per Boss manual. Turned on headlights and heard clicking (relay?) from within the dash, but no lights. Ideas?
     
  2. elecblu

    elecblu Member
    Messages: 79

    Double check the configuration on your headlight adaptors and polarity plug
     
  3. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    Make sure they are on the B side I believe. If you look at the adapter there is a A and B side on the plus where they plug into the harness. Make sure they are both on the same side. If its not B side then check the A side.
     
  4. surypap3

    surypap3 Junior Member
    from WDC
    Messages: 3

    Not looking at the adapter right now but operating from recall, the plugs from the truck harness only clip into the adapter one way for the locking clips to work.

    The high and low beam (adapter to bulbs) were clearly marked (gray to gray and black to black) and clip in one way.

    Do you mean I may have switched the high and low beam wires from truck harness to plow adapter?

    Thanks

    Jack
     
  5. RBRONKEMA GHTFD

    RBRONKEMA GHTFD 2000 Club Member
    Messages: 2,592

    No where the gray to gray and black to black go in together there is a A and B side. Make sure they are all on the same side. Like A for instance. If its not A then its B.
     
  6. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Should all be on the "A" side. If all four are correct and this is on a 5 relay pack harness be sure you have the red/white wire on the correct battery terminal and the vehicle option connector is plugged together correctly as well. Incorrect hookup will cause the relays to chatter.
     
  7. surypap3

    surypap3 Junior Member
    from WDC
    Messages: 3

    Thanks. I try again with your notes.