1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

'94 Bronco lock-out hubs

Discussion in 'Ford Trucks' started by repo_man62, Dec 28, 2005.

  1. repo_man62

    repo_man62 Senior Member
    Messages: 502

    Anyone have a clear diagram or pics of how it's put together? Yea I screwed up.
     
  2. MickiRig1

    MickiRig1 PlowSite Veteran
    Messages: 3,617

    What did you do? Put them in wrong or what? Manual hubs I take it?
     
  3. repo_man62

    repo_man62 Senior Member
    Messages: 502

    All I did was take the button and ring off to check the o-ring due to some leakage from it. I didn't pay attention to the position when I took it off ...set it down...and put it back on... it won't engage anything. When you put it in the free position, (which is the only position you can move it to), it "moves" on it's own to the spot between lock and free.:angry:
     
  4. MickiRig1

    MickiRig1 PlowSite Veteran
    Messages: 3,617

    They really don't need to be relaced in a certain position,I always try to have the Lock/Free at the top never ends up there. You didn't take the center screw out of the selector dial did you? I think you need to pull the internal parts of the hub and look for a broken return spring, retainer ring or the retainer screw is sheared. It may even just need cleaned and lightly greased. There is a wire bale inside the bore that retains the hub,wipe out the grease and look carefully.It's not just the circlip on the shaft end that holds it in.
     
  5. repo_man62

    repo_man62 Senior Member
    Messages: 502

    I got it figured out...thanks.
     
  6. MickiRig1

    MickiRig1 PlowSite Veteran
    Messages: 3,617

    What was the problem?