1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

9'2" V XT Fuse Problem

Discussion in 'Boss Plows Discussion' started by odd1or2even, Nov 1, 2010.

  1. odd1or2even

    odd1or2even Senior Member
    Messages: 115

    I recently hooked up my plow to show it off for advertising purposes and the fuse under the hood (red wire) blew again. It's only a 10 amp, and it's the third time now it's blown trying to hook up the plow.

    I hooked my controller up, and tried to press the down button to go in "float" but I got nothing. I mounted the plow to the truck. Hooked the wires up and flipped the locks on, then tried the controller (off/on/off/on) to see if resetting it would do it. Still had nothing... so I checked under the hood and it was the little ten amp fuse right off the battery that blew. After changing, the controller lit up again and worked...

    What causes this to blow? I haven't had a problem with this with my 8'2" V or my 7'6" straight... do I have a short or what? Thanks for your help...

  2. Pinky Demon

    Pinky Demon PlowSite.com Addict
    from Ohio
    Messages: 1,121

    I would think most def. a short. Take it into your dealer and have them poke around.
  3. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Yes you have a short, likely due to a poor install. Turn the controller on with the plow disconnected and continue to press all the function buttons repeatedly for a few minutes. If it blows the fuse then the issue is on the truck side (most likely). If it doesn't, connect the plow and try again, if it blows it now then you know it's on the plow side.

    A good visual inspection is in order too.