1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

9' MM2 dosnt operate!

Discussion in 'Truck & Equipment Repair' started by cbeaur, Sep 29, 2011.

  1. cbeaur

    cbeaur Junior Member
    from Mass
    Messages: 11

    I have a 9' MM2 approx. 6 yrs old. I went to move it yesterday and it will not go up or left or right. I can hear the solenoid clicking under the hood but no movement. Only thing that works are the lights on the plow. Connectors are clean and there apperars to be no tear in the wires. Any ideas?
     
  2. LON

    LON Senior Member
    Messages: 749

    12V going out to the motor?
    If there is 12V at the stud on the motor than I'd suspect the motor is seized.
     
  3. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    Try hot wiring the motor with some jumper cables and a battery.
     
  4. FordFisherman

    FordFisherman PlowSite.com Addict
    from 06611
    Messages: 1,593

    bad solenoid is my guess...mine did the same last year.
     
  5. woodchuck2

    woodchuck2 Senior Member
    Messages: 304

    My MM2 8' did the same thing several yrs ago and i had a broken ground wire inside the back side of the plug.
     
  6. FordFisherman

    FordFisherman PlowSite.com Addict
    from 06611
    Messages: 1,593

    and the correct answer is....
     
  7. AGMI

    AGMI Member
    from NE Mass
    Messages: 36

    Its either a bad ground after the selenoid or a bad motor. Jumping the motor from a 12v source is a good idea to diagnose. A new motor will run u about $145.
     
  8. cbeaur

    cbeaur Junior Member
    from Mass
    Messages: 11

    its the motor, thanks guys!