1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

8611LP install problem.

Discussion in 'Blizzard Plows Discussion' started by Lazer Man, Dec 2, 2014.

  1. Lazer Man

    Lazer Man Senior Member
    from SW Pa.
    Messages: 139

    We are installing a 8611lp on an '07 dodge 3500 we have all wiring hooked up but when we try to hook plow to truck we have nothing. The controller is flashing the green light off n on. We have power to the motor solenoid but nothing happens. Tried different controller from other truck same thing happens. I hooked plow up to another truck plow works fine. I've checked my wiring a million times can't find any problem. Any and all help would be greatly appreciated
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,983

    Try the trk with another plow
     
  3. Lazer Man

    Lazer Man Senior Member
    from SW Pa.
    Messages: 139

    I did and nothing I should say this is an pp2 plow I changed out the wiring on the truck side harness from battery to plow plug also changed out the controller wiring nothing I did changed anything. We also swapped out lighting control box that did nothing also I just can't figure out what the problem is
     
  4. magnatrac

    magnatrac PlowSite.com Addict
    Messages: 1,055

    Do you have the controller on when trying to mount the plow ? It needs to be in the off position for the power hitch to work.
     
    Last edited: Dec 2, 2014
  5. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,983

    The inside power wire good?
    Plow grill connectors hooked up?
    Power at the solenoid small wires?
     
  6. Sharpcut 1

    Sharpcut 1 Senior Member
    Messages: 386

    4 prong wiring harness labeled battery hooked up to power cord lead off battery and not other side (4 prong harness are identecal connectors and can get hooked up backwards) Is the orange backlight coming on your controller? The green light is float and should NOT be blinking, if anything it should be red light blinking. Both 10 amp fuses at iso module good? Black w orange ground wire at iso module plugged in?
     
  7. Lazer Man

    Lazer Man Senior Member
    from SW Pa.
    Messages: 139

    Sharpcut thank you buddy that was the problem I didn't do the wiring but was trying to figure problem out you found it thanks again for your help.