1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

8611 LP wont angle right

Discussion in 'Blizzard Plows Discussion' started by LapeerLandscape, Feb 5, 2015.

  1. LapeerLandscape

    LapeerLandscape PlowSite.com Addict
    Messages: 1,613

    I have 8611 LP PH2 that wont angle right, the motor runs and it acts like it wants to move a little and when you let off the button it springs back. I haven't pulled the truck in yet should I start right at the S5 valve or somewhere else first.
     
  2. damian

    damian Senior Member
    Messages: 330

    Yea check to see if the coil is magnetized by holding a screw driver to it while someone operates it. I just went thru this with an 8100. ill bet the S6 is Being stuck open by a piece of debris and is always "on". In my case the pass side piston came apart at the end of the rod. It would only take a few minutes to pull both S5 and S6 spools out check the plunger on the end with a small screwdriver see if the spool springs down and back,check the holes for crap.bring a 3/4 and 7/8 deep socket and a small drain pan.good luck.
     
  3. LapeerLandscape

    LapeerLandscape PlowSite.com Addict
    Messages: 1,613

    We pulled the S5 and it seemed to worked fine then we pulled the S6 it almost acted like it was stuck and then started working. Put it back together and it works for now.
     
  4. damian

    damian Senior Member
    Messages: 330

    nice work. if the problem happens a few more times you may have an angle piston coming apart.
     
  5. PALS Landscapin

    PALS Landscapin Senior Member
    Messages: 120

    Check your plug connector to. I had the same problem and there was corrosion on the connectors,